Comware

 View Only
last person joined: 2 days ago 

Expand all | Collapse all

simple trunk between 5700 and HP 3800

Jump to Best Answer
This thread has been viewed 43 times
  • 1.  simple trunk between 5700 and HP 3800

    Posted Dec 30, 2021 01:19 PM
    I am trying to do what i thought was a simple vlan trunk between this 10gb switch (5700) and our normal core router/switch (3800). First off, i spent a few days playing around with comware and learning the syntaxes as they are completely different than the arubas. I have looked all over for how to do this and cant figure out what the heck i am doing wrong.

    Goal is a basic trunk that passes all vlans, from the 3800 to the 5700. I tried the below setup, but i cannot ping the gateway (vlan interface ip address on the aruba 3800) from the 5700. That is my test to see if its working, i havent hooked up any machines yet. Additionally, the command "display ip routing-table" does not return any static route i am setting. all the interfaces are either InLoop0 or NULL0.... however "dis route-static routing-table" DOES show the static route i had configured. I also tried with no static route and its the same deal.

    5700 side
    interface Ten-GigabitEthernet1/0/40
     description "uplink to 3800"
     port link-type trunk
     port trunk permit vlan all
    ​

    3800 side:
    interface 50
       name "uplink to 10GB Data"
       tagged vlan 5,8,32,48,64,250,255
       exit
    ​

    Should this not just work? Do i need ip addresses on the vlan interfaces? is this the ip-subnet command? Because it appears i can only set an ip address on the gige management interface. In another guide i have configured that as follows and it is working:

    interface M-GigabitEthernet0/0/0
     description "management interface"
     ip binding vpn-instance mgmt
     ip address 10.0.255.10 255.255.255.0
    ​

    Routes (the management interface works and i can manage the switch over the copper link). As i understand they are separate networks (management vs 10gb) and so wont conflict in terms of routing.
     ip route-static 0.0.0.0 32 10.0.255.1 preference 1
     ip route-static vpn-instance mgmt 0.0.0.0 0 10.0.255.1
    ​

    So then i issue:

    [DataRM-Core-Ten-GigabitEthernet1/0/40]ping 10.0.255.1
    Ping 10.0.255.1 (10.0.255.1): 56 data bytes, press CTRL_C to break
    Request time out
    Request time out
    Request time out
    Request time out
    Request time out
    
    --- Ping statistics for 10.0.255.1 ---
    5 packet(s) transmitted, 0 packet(s) received, 100.0% packet loss
    ​

    I also tried pinging virtual interfaces on all the other subnets (vlans) i am routing. and nothing will ping over this link. Putting the management port ina  "VPN" keeps it seperate from what i understand. Which is why that is working fine.

    I am way more familiar with cisco switches. What am i missing here? I believe i only want layer 2 so i dont think i need vlans to have ip addresses. All routing is done by the 3800, i just want to trunk over all the vlans. The end goal being to have trunked vlan 10gb ports to my vmware servers and let the virtual nics on there get tagged and used. But i am just confusing myself reading and reading. There must be a simple solution.

    Any help appreciated. 



    ------------------------------
    --- --
    ------------------------------


  • 2.  RE: simple trunk between 5700 and HP 3800

    MVP GURU
    Posted Dec 30, 2021 09:10 PM
    Hi, what is the Native VLAN Id (PVID) of the Ten-GigabitEthernet1/0/40 interface of the 5700? just to be sure you match VLAN memberships of the corresponding port 50 of your HP 3800...I mean if port 50 is just a tagged member of VLAN Ids 5, 8, 32, 48, 64, 250 and 255 this means that port 50 is orphaned of a Native VLAN Id (indeed it is not an untagged member of any VLAN Id, neither of the default VLAN id 1). I will try to verify this first: having a 1-to-1 matching between VLAN memberships on 5700 side and 3800 side...only then I will eventually check the upper layer (IP)...if you're just transporting a series of VLAN Ids from the 5700 to the 3800 and the SVI of each involved VLAN Id is defined on the 5700 then you should be able to ping these SVIs from an host properly connected on the 3800 or directly from the 3800 if a VLAN Id has a proper IP address assigned (matching the segment IP address of the corresponding VLAN Id), here we guess there aren't ACLs on the 5700 blocking that.

    ------------------------------
    Davide Poletto
    ------------------------------



  • 3.  RE: simple trunk between 5700 and HP 3800

    Posted Dec 31, 2021 12:47 PM
    "the SVI of each involved VLAN Id is defined on the 5700 "

    The vlans are defined, do they need IP addresses on the vlans though? Is that the ip-subnet-vlan command? That is the only way i can see to set the ip address on a vlan. But not sure if that is correct. Of if that is what you mean. If they simply need to be defined, then yes i have done that:

    [DataRM-Core]dis vlan
     Total VLANs: 8
     The VLANs include:
     1(default), 5, 8, 32, 48, 64, 250, 255
    [DataRM-Core]
    


    I read about the pvid business, i would assume its default of 1.

    There are no ACLs on the 5700. the config is very stock. the only fancy bit i did was isolate the mgmt interface with this "vpn" thing.

    i tried setting 255 untagged on the 3800 on that trunk port and also setting the pvid on tengig port 40 with this command:

    port trunk pvid vlan 255
    seems to make no difference. still cant ping from the switch. But that is the only test i am doing as no other hosts are connected. Does the 5700 need ip addresses on its vlans? 
    I tried this now, set an ip address on vlan 255 on the 5700 and i cant ping it from the 3800. or vice versa... i am missing something and i feel it should be super simple :P





    ------------------------------
    --- --
    ------------------------------



  • 4.  RE: simple trunk between 5700 and HP 3800

    EMPLOYEE
    Posted Dec 31, 2021 12:39 PM
    Hello keepontrunking,

    You need to have Vlan interface as parnassus mentioned to be able to ping from the 5700 to 3800. e.g. if you have vlan 32 with a proper ip address on under vlan interface (which is the L3 interface for the vlan) then you should be able to reach 3800 interface in vlan 32 if there is one.
    Hope this helps!

    ------------------------------
    -Alex-
    ------------------------------



  • 5.  RE: simple trunk between 5700 and HP 3800

    Posted Dec 31, 2021 12:54 PM
    i did this just now. does not seem to make a difference:

    #
    vlan 255
     name NetworkManagement
     ip-subnet-vlan 0 ip 10.0.255.90 255.255.255.0
    #
    ​

    #
    interface Ten-GigabitEthernet1/0/40
     description "uplink to rt"
     port link-type trunk
     port trunk permit vlan all
     port trunk pvid vlan 255
    #


    3800:

    RT(eth-50)# show run int 50
    
    Running configuration:
    
    interface 50
       name "DataRM-Core 10GB Data"
       tagged vlan 5,8,32,48,64,250
       untagged vlan 255
       exit
    
    RT(eth-50)#
    

    RT(eth-50)# show run vlan 255
    
    Running configuration:
    
    vlan 255
       name "NetworkManagement"
       tagged 13,24-36
       untagged 44-50
       ip helper-address 10.0.64.13
       ip address 10.0.255.1 255.255.255.0
       exit
    
    RT(eth-50)#
    

    [DataRM-Core-vlan255]ping 10.0.255.1
    Ping 10.0.255.1 (10.0.255.1): 56 data bytes, press CTRL_C to break
    Request time out
    Request time out
    Request time out
    Request time out
    Request time out
    
    --- Ping statistics for 10.0.255.1 ---
    5 packet(s) transmitted, 0 packet(s) received, 100.0% packet loss
    [DataRM-Core-vlan255]\
    





    ------------------------------
    --- --
    ------------------------------



  • 6.  RE: simple trunk between 5700 and HP 3800
    Best Answer

    EMPLOYEE
    Posted Dec 31, 2021 01:05 PM
    Hello keepontrunking,

    You need to configure vlan interface ip address as the following example on 5700, please adjust for your network:

    interface Vlan-interface255
    description TEST
    ip address 10.0.255.91 255.255.255.0

    Hope this helps!


    ------------------------------
    -Alex-
    ------------------------------



  • 7.  RE: simple trunk between 5700 and HP 3800

    Posted Dec 31, 2021 01:23 PM
    OMG it worked! ok that was the missing piece... the vlan just by nature of it being a vlan isn't its own interface? because on the 3800 it works that way. Stupid comware being so confusing!!!

    Do i need one interface per vlan with an ip on it? like for instance to pass vlan 64 traffic i need a vlan-interface64 command?

    ------------------------------
    --- --
    ------------------------------



  • 8.  RE: simple trunk between 5700 and HP 3800

    EMPLOYEE
    Posted Dec 31, 2021 01:31 PM
    Hello keepontrunking,

    In order just to pass traffic you do not need vlan interface (SVI). You need it in order if you need the switch to communicate with other switches or devices or if you do routing on it. Other way you may need only one vlan interface in order to reach the switch and manage it when not reaching it from the management port for example.
    For example if you have PCs in vlan 64 you need just to define vlan 64 assign to the needed ports (you do not need vlan interface for this vlan if you will not reach or route the switch through this vlan) and it will pass the traffic through the switch to reach their gateway which is the 3800 switch.
    Hope this helps!

    ------------------------------
    -Alex-
    ------------------------------



  • 9.  RE: simple trunk between 5700 and HP 3800

    MVP GURU
    Posted Jan 03, 2022 06:03 AM
    Hi!

    I would highlight that SVIs are necessary IF IP routing between directly connected VLANs is needed and it is required to happen internally to your network (Hosts will use those SVIs as their Default Gateways) indeed SVIs aren't necessary if you just need to propagate one or more VLAN Ids between switches (because it is supposed that those packets are switching between Layer 2 connected switches), provided that those Switches belong to the same network topology (or to propagate one or more VLAN Ids to a Firewall acting as THE IP Router for your network).

    Example:

    Host A (VLAN unaware and with IP addressing properly set) <-> Port operating in Access Mode (PVID = x) -- Switch A -- Port operating in Trunk Mode (x Tagged or PVID = x) <-- inter-link between Switch A and B --> Port operating in Trunk Mode (x Tagged or PVID = x and - in any case - matching what was used on Switch A port operating in "Trunk Mode") -- Switch B -- Port operating in Access Mode (PVID = x) <-> Host B (VLAN unaware and with IP addressing properly set (and matching the one adopted on Host A)

    No SVI is needed to grant Host A and B speak together: Host A will be able to ping Host B and vice-versa (provided that Host OS's firewall applications aren't blocking relevant ICMP traffic).

    ------------------------------
    Davide Poletto
    ------------------------------



  • 10.  RE: simple trunk between 5700 and HP 3800

    Posted Feb 25, 2022 05:18 AM
    Thank you for the solution. My Query has been solved.

    ------------------------------
    Mary Houck
    ------------------------------