Wireless Access

 View Only
last person joined: 12 hours ago 

Access network design for branch, remote, outdoor and campus locations with Aruba access points, and mobility controllers.
Expand all | Collapse all

Setting up a 7005 as my home router

Jump to Best Answer
This thread has been viewed 24 times
  • 1.  Setting up a 7005 as my home router

    EMPLOYEE
    Posted Apr 29, 2022 02:20 PM

    What license(s) do I need for ip access-list creation?
    Trying to setup a 7005 MM to be my home router.
    Creating my WAN ip access list yields a license error:
     
    ip access-list session SPECTRUM-LINK-ACL
    any any svc-dhcp permit
    any any any deny
     
    ----------------------------------
    (Aruba7005) ^*[mynode] (config) #ip access-list session SPECTRUM-LINK-ACL
    ^
    ERROR: Feature is not enabled in the license
     
    I have never-ending RFP, AP, and NGP licenses
    (Aruba7005-1) ^*[mynode] #show license
    License Table
    -------------
    Key Installed Expires(Grace period expiry) Flags Service Type
    --- --------- ---------------------------- ----- ------------
    theraini-nspainfa-llsmainl-yinthepl-ainsoron-lan 2020-08-13 21:08:12 Never E RF Protect: 32
    theraini-nspainfa-llsmainl-yinthepl-ainsoron-lan 2020-08-13 21:08:23 Never E Access Points: 32
    theraini-nspainfa-llsmainl-yinthepl-ainsoron-lan 2020-08-13 21:07:41 Never E Next Generation Policy Enforcement Firewall Module: 32
     
    License Entries: 3
     
    Flags: A - auto-generated; E - enabled; S - Subscription; R - reboot required to activate; D - Not enabled on license client
     
    Note: Time under 'Installed' for Subscription licenses is the license generation time.
     
    (Aruba7005-1) ^*[mynode] #show clock
    Fri Apr 29 13:58:53 EDT 2022
     
    (Aruba7005-1) ^*[mynode] #show version
    Aruba Operating System Software.
    ArubaOS (MODEL: Aruba7005-US), Version 8.5.0.7
    (c) Copyright 2020 Hewlett Packard Enterprise Development LP.
    Compiled on 2020-03-20 at 14:03:55 UTC (build 74786) by p4build
     
    Help?

    Full Config mapped out to replace an MSR2003
    =====================================
    ! LAN
    interface vlan 10
    ip address 10.0.0.50 255.255.255.0
    ip nat inside
    description "LAN-Home1"

    interface vlan 11
    ip address 10.1.0.50 255.255.255.0
    ip nat inside
    description "LAN-Home2"

    interface gigabitethernet 0/0/0
    description "LAN-Home1-Downlink"
    trusted
    trusted vlan 1-4094
    switchport access vlan 10
    no poe
    lldp transmit
    lldp receive

    interface gigabitethernet 0/0/1
    description "LAN-Home1-Downlink"
    trusted
    trusted vlan 1-4094
    switchport access vlan 11
    no poe
    lldp transmit
    lldp receive

    ! WAN
    interface vlan 100
    ip address dhcp-client
    ip nat outside
    description "WAN-Spectrum"

    !
    interface gigabitethernet 0/0/3
    description "WAN-Spectrum-Uplink"
    trusted
    trusted vlan 1-4094
    ip access-group "SPECTRUM-LINK-ACL" session
    switchport access vlan 100

    !
    ip access-list session SPECTRUM-LINK-ACL
    any any svc-dhcp permit
    any any any deny

    !
    ip default-gateway import dhcp



    ------------------------------
    Jeff Brownell
    ------------------------------


  • 2.  RE: Setting up a 7005 as my home router

    EMPLOYEE
    Posted Apr 30, 2022 04:31 AM
    Is it enabled?
    show license-pool-profile-root

    If not then it is enabled by doing the following.

    [mm] (config) #license-pool-profile-root
    [mm] (License root(/) pool profile) #pefng-licenses-enable
    [mm] (License root(/) pool profile) #exit
    [mm] (config) #exit
    [mm] #write memory

    ------------------------------
    Michael Clarke
    ------------------------------



  • 3.  RE: Setting up a 7005 as my home router

    EMPLOYEE
    Posted Apr 30, 2022 11:06 AM
    (Aruba7005-1) ^*[mynode] #show license-pool-profile-root
    ERROR: Command can be executed only on /mm.

    Does the controller need to be an mm? Or do I need to move to the /mm context?
    How do I make it an mm or move into the /mm context?

    (Aruba7005-1) ^*[mynode] #show version
    Aruba Operating System Software.
    ArubaOS (MODEL: Aruba7005-US), Version 8.5.0.7
    ..
    Compiled on 2020-03-20 at 14:03:55 UTC (build 74786) by p4build

    ROM: System Bootstrap, Version CPBoot 1.0.2.0 (build 46859)
    Built: 2014-10-31 10:10:57
    Built by: p4build@re_client_46859

    ------------------------------
    Jeff Brownell
    ------------------------------



  • 4.  RE: Setting up a 7005 as my home router
    Best Answer

    EMPLOYEE
    Posted Apr 30, 2022 08:01 PM
    Figured it out:

    cd /mm

    show license-pool-profile-root

    [mm] (config) #license-pool-profile-root
    [mm] (License root(/) pool profile) #pefng-licenses-enable
    [mm] (License root(/) pool profile) #exit
    [mm] (config) #exit
    [mm] #write memory

    (Aruba7005-1) *[mm] (License root(/) pool profile) #show license-pool-profile-root

    License root(/) pool profile
    ----------------------------
    Parameter Value
    --------- -----
    enable PEFNG feature Enabled
    enable RFP feature Disabled
    enable ACR feature Disabled
    enable WebCC feature Disabled

    (Aruba7005-1) *[mm] (License root(/) pool profile) # ?
    acr-license-enable enable ACR feature
    no Delete Command
    pefng-licenses-enable enable PEFNG feature
    rfp-license-enable enable RFP feature
    webcc-license-enable enable WebCC feature

    (Aruba7005-1) ^*[mm] (License root(/) pool profile) #acr-license-enable
    (Aruba7005-1) ^*[mm] (License root(/) pool profile) #rfp-license-enable
    (Aruba7005-1) ^*[mm] (License root(/) pool profile) #webcc-license-enabl
    (Aruba7005-1) ^*[mm] (License root(/) pool profile) #
    (Aruba7005-1) ^*[mm] (License root(/) pool profile) #write mem

    Saving Configuration...

    Configuration Saved.
    (Aruba7005-1) *[mm] (License root(/) pool profile) #
    (Aruba7005-1) *[mm] (License root(/) pool profile) #
    (Aruba7005-1) *[mm] (License root(/) pool profile) #show license-pool-profile-root

    License root(/) pool profile
    ----------------------------
    Parameter Value
    --------- -----
    enable PEFNG feature Enabled
    enable RFP feature Enabled
    enable ACR feature Enabled
    enable WebCC feature Enabled

    (Aruba7005-1) *[mm] (config) #ip access-list session SPECTRUM-LINK-ACL
    (Aruba7005-1) ^*[mm] (config-submode)# any any svc-dhcp permit
    (Aruba7005-1) ^*[mm] (config-submode)# any any any deny
    (Aruba7005-1) ^*[mm] (config-submode)#exit
    (Aruba7005-1) ^*[mm] (config)#

    (Aruba7005-1) ^*[mm] (config) #interface gigabitethernet 0/0/3
    (Aruba7005-1) ^*[mm] (config-submode)# description "WAN-Spectrum-Uplink"
    (Aruba7005-1) ^*[mm] (config-submode)# trusted
    (Aruba7005-1) ^*[mm] (config-submode)# trusted vlan 1-4094
    (Aruba7005-1) ^*[mm] (config-submode)# ip access-group session SPECTRUM-LINK-ACL
    (Aruba7005-1) ^*[mm] (config-submode)# switchport access vlan 100
    (Aruba7005-1) ^*[mm] (config-submode)#exit
    (Aruba7005-1) ^*[mm] (config) #write mem
    Saving Configuration...
    Configuration Saved.

    Thank you,
    -Jeff

    ------------------------------
    Jeff Brownell
    ------------------------------