Wireless Access

last person joined: 16 hours ago 

Access network design for branch, remote, outdoor and campus locations with Aruba access points, and mobility controllers.
Expand all | Collapse all

Custom Captive Portal - no login possible

Jump to Best Answer
  • 1.  Custom Captive Portal - no login possible

    Posted Apr 28, 2017 12:47 PM

    Hello!

     

    I've uploaded a custom Captive Portal Page to a aruba 7030 controller as described in this appendix:

    Reason - the built in CP Page dont scale (mobile devices)....

     

    Now i stuck on an login issue.
    If i enter the username and password, nothing happens, the CP loads again.
    No error messages in the box above the user box, the user dont get authenticated.

    The built in pages are working properly.


    The issue exists even if i copy the whole code of an built in CP page into a custom page.
    All links and sources of the page are available.

     

    Does anybody knows this issue?

     

    Regards!



  • 2.  RE: Custom Captive Portal - no login possible

    Posted Apr 28, 2017 09:32 PM

    There are quite a few ways that you could have broken it, from controller configuration to HTML.  Where do you want to start?



  • 3.  RE: Custom Captive Portal - no login possible

    Posted Apr 29, 2017 03:50 PM

    Because of the fact that the html code from the built in site is not working as custom upload, i would say at the controller configuration.

    I loadet up the Captive Portal page (top level) and the content (background).
    Then i changed the path to the custom page in the L3 authentication captive portal profile.

     

    Im at work on tuesday again, than i can post more details from the configuration if needet.

     

    Thank you!

    Regards



  • 4.  RE: Custom Captive Portal - no login possible
    Best Answer

    Posted May 03, 2017 04:43 AM

    Hello!

     

    This topic solved my issue:

    http://community.arubanetworks.com/t5/Security/Stuck-at-Captive-Portal-Login/m-p/251846

     

    My problem was that i copied the default html code.
    If the default code is used in a custom Captive Portal, the form has to be changed:

     

    Default:

    <form action="login" id="regform" method="post" autocomplete="off" title="Form used by registered users to login">

    Custom:

    <FORM method="post" autocomplete="off" ACTION="/auth/index.html/u">

     After updating this line, it worked perfectly.

     

     

     

     

     



  • 5.  RE: Custom Captive Portal - no login possible

    Posted May 05, 2017 07:01 AM

    You can leave everything as it is, you just need to change action="login" to

    ACTION="/auth/index.html/u"

    for it to work. This is where login data will be sent to. 



  • 6.  RE: Custom Captive Portal - no login possible

    Posted May 05, 2017 07:05 AM

    Thank you!
    Yea, i was able to resolve it with this line...

     

     



  • 7.  RE: Custom Captive Portal - no login possible

    Posted Sep 12, 2017 05:07 PM

    We are having issue with our custom captive portal, I tried using the sample template (found here: https://community.arubanetworks.com/aruba/attachments/aruba/aaa-nac-guest-access-byod/10187/1/Custom%20Captive%20Portal%20Web%20Guest%20Access.pdf) the problem is clicking on the I ACCEPT doesn't do anything.  I'm assuming it's something to do with the form as well - except we don't require any login - just click on "I ACCEPT" button.   Any idea how I need to change the html for this to work?

     

    THanks in advance for any help you can provide.



  • 8.  RE: Custom Captive Portal - no login possible

    Posted Sep 18, 2017 02:50 AM

    Hi!

     

    Sorry for the delay, I was on vacation...

     

    Because of the Info on page one of the PDF

    Spoiler
    Product and Software: This article applies to all Aruba controllers and ArubaOS version 2.5 and later.

    I think the template is a bit older.

     

    If you don't resolve your issue yet, I recomend to compare the code of the sample template and the original built in default html of your controller.

    There should be a similar button, try to customize the template along the original code.

     

    Good luck!

     



  • 9.  RE: Custom Captive Portal - no login possible

    Posted May 05, 2017 08:29 AM
    You also need to have a valid public CA-signed captive portal certificate.


  • 10.  RE: Custom Captive Portal - no login possible

    Posted May 05, 2017 08:41 AM

    Hi Tim!

     

    I set the Captive Portal to use HTTP.
    Apple CNA and other browsers pops up without a certificate warning.
    Could there be a problem to use CP with HTTP without an public certificate?


    At the moment i see no reason to use CP with HTTPS.

     

     



  • 11.  RE: Custom Captive Portal - no login possible

    Posted May 05, 2017 08:46 AM
    CNA will not pop via HTTPS without a valid certificate. The only time HTTP should be used is with click-to-accept workflows or informational redirects.


  • 12.  RE: Custom Captive Portal - no login possible

    Posted May 05, 2017 09:24 AM

    Hi!

     

    OK, thats right.
    We just need get an certificate, than we can use HTTPS.

     

    Thank you!