Controllerless Networks

last person joined: 10 hours ago 

Aruba Instant Wi-Fi: Meet the controllerless Wi-Fi solution that's easy to set-up, is loaded with security and smarts, and won't break your budget.
Expand all | Collapse all

Having weird DNS issues since update to firmware 6.4.2.6-4.1.1.9_51442

Jump to Best Answer
  • 1.  Having weird DNS issues since update to firmware 6.4.2.6-4.1.1.9_51442

    Posted Sep 17, 2015 03:11 PM

    We have 81 Aruba 225 IAP's in a cluster. We have a VLAN setup for our wireless traffic and our wired traffic runs on a different VLAN. Before I updated our firmware to version  6.4.2.6-4.1.1.9_51442, everything worked fine, but now I am unable to resolve DNS in our reverse lookup zone, forward lookup works fine. Here is the kicker... if I cable the PC in, everything works fine. Our VLANS are routed on a layer 3 switch, no filtering or anything, it just routes all traffic between VLAN's. Everything else works fine: Internet, Forward DNS lookup, ping, etc... any ideas???


    #AP225


  • 2.  RE: Having weird DNS issues since update to firmware 6.4.2.6-4.1.1.9_51442

    Posted Sep 17, 2015 03:39 PM

    Hi

     

    i'm having a similar problem after upgrading our IAP 115's to this version. We are only a small setup with 9 APs, no vLan and a simple setup. I did the upgrade on Monday evening and on Tuesday had masses of Staff telling me they couldn't access network drives, printers or certain websites! After investigation I found that laptops where not indentifing the network as a private/domain network and thus getting a public profile and public firewall. This was blocking everything and causing the issues. So I tried plugging a laptop in and bang everything worked with the laptop now saying it was on a domain network. This rules out any server issues etc. So to rule out OS I tired the same thing Windows 7, 8.1 and 10 all with the same results. Like yourself I thought DNS and restarted the domain controller to be on the safe side. I also updated all of i the laptops drivers to the latest versions etc. Still no joy. It has to be this firmware upgrade causing the issue. So I today I contacted support to be told sorry your IAPs are more than 90 old and thus you need to buy a care package before we will investigate. I thought these IAPs came with a lifetime warranty! Furthermore this issue has been created by their firmware upgrade and thus not my fault so they should forget warranties and fix it fast, I'm now trying to work out how to downgrade the IAPs. Any one else with these issues after the upgrade or any ideas on how to fix it? Thanks



  • 3.  RE: Having weird DNS issues since update to firmware 6.4.2.6-4.1.1.9_51442
    Best Answer

    Posted Sep 17, 2015 03:52 PM
      |   view attached

    EDIT:

     

    Instant 4.1.1.10 has been released.  Please upgrade to that version of code to sidestep any issues with 4.1.1.9

     

    Release Notes attached

     

     

     



  • 4.  RE: Having weird DNS issues since update to firmware 6.4.2.6-4.1.1.9_51442

    Posted Sep 17, 2015 04:01 PM

    Hi

     

    Thank you for your reply. I've sent you a PM. Hopefully I can then downgrade and get this working again tomorrow.



  • 5.  RE: Having weird DNS issues since update to firmware 6.4.2.6-4.1.1.9_51442

    Posted Sep 18, 2015 03:57 AM

    Thank you for your help with this yesterday. I can confirm downgrading to 4.1.1.8 has fixed the problem.



  • 6.  RE: Having weird DNS issues since update to firmware 6.4.2.6-4.1.1.9_51442

    Posted Sep 18, 2015 12:25 PM

    I would suggest Aruba remove this buggy firmware, until they get the issue worked out. Also, since our total Aruba AP IAP population is over 600... I really hope I dont have to go to each one and factory reset it to go back to a previous firmware!!!



  • 7.  RE: Having weird DNS issues since update to firmware 6.4.2.6-4.1.1.9_51442

    Posted Sep 18, 2015 12:36 PM

    Here are my symptoms, so others do not have such a hard time figuring out that the Aruba firmware is causing the issue... I will also notify other state, county and city agencies as well as our school districts, so they are aware not to upgrade to this version of firmware due to the issues that it causes.

     

    1. While connected to the wireless users get prompted to authenticate to all server shares

    2. The content of some network shares will be missing

    3. You will get NSLookup results using the server hostname and no results if using IP

    4. If you cable in... all of your problems will go away!

     



  • 8.  RE: Having weird DNS issues since update to firmware 6.4.2.6-4.1.1.9_51442

    Posted Sep 18, 2015 02:29 PM

    Just wondering.... will the early release version "ArubaInstant_Centaurus_6.4.3.1-4.2.0.0_51112" fix my issue or do I need to go backwards?



  • 9.  RE: Having weird DNS issues since update to firmware 6.4.2.6-4.1.1.9_51442

    Posted Sep 18, 2015 02:34 PM
    It is advised to go back to what you upgraded from or 4.1.1.8.


  • 10.  RE: Having weird DNS issues since update to firmware 6.4.2.6-4.1.1.9_51442

    Posted Sep 18, 2015 02:36 PM

    Can you send me the 4.1.1.8 link? I sent you a PM... still waiting to hear back from you.



  • 11.  RE: Having weird DNS issues since update to firmware 6.4.2.6-4.1.1.9_51442

    Posted Sep 18, 2015 02:38 PM
    I replied asking you what model of access point do you need the code for. What model?


  • 12.  RE: Having weird DNS issues since update to firmware 6.4.2.6-4.1.1.9_51442
    Best Answer

    Posted Sep 18, 2015 06:00 PM

    I can also confirm that downgrading to firmware version 6.4.2.6-4.1.1.8_50989 fixed my issue. I did open a support case on this issue, but the person that assisted me was not aware of the issue. So... THANK YOU for your help!



  • 13.  RE: Having weird DNS issues since update to firmware 6.4.2.6-4.1.1.9_51442

    Posted Sep 19, 2015 05:08 PM

    I'm having the same issues with an IAP-105. DNS resolves very slowly, all wireless phones and tablets seem to hang on nearly any web based app. could I get the downgrade as well please?



  • 14.  RE: Having weird DNS issues since update to firmware 6.4.2.6-4.1.1.9_51442

    Posted Sep 21, 2015 04:29 PM

    I don't know if this is the same issue. I upgraded to 6.4.2.3-4.1.1.5_51442 on Saturday and today any new devices don't get an ip from our central dhcp server. The server issues the IP but it never gets passed on to the client by the AP. If the device renews an existing lease it is fine, but any attempt to get an IP times out for new leases. Again, the dhcp sever shows the lease start but the client never gets the lease in hand and defaults to the 169.x bs address. Happens on every type of client, pc, mac, iphone, ipad, android.

     

    where can I find the previous version? Aruba does a great job of hiding them.

     

    M



  • 15.  RE: Having weird DNS issues since update to firmware 6.4.2.6-4.1.1.9_51442

    Posted Sep 21, 2015 04:34 PM
    It is not related. Did you recently upgrade?


  • 16.  RE: Having weird DNS issues since update to firmware 6.4.2.6-4.1.1.9_51442

    Posted Sep 21, 2015 05:06 PM

    Indeed I did. on saturday Sept 19th

     

    M



  • 17.  RE: Having weird DNS issues since update to firmware 6.4.2.6-4.1.1.9_51442

    Posted Sep 21, 2015 05:07 PM

    by the way, I am trying to find the previous firmware and can't. do you have a url I can go to?

     

    Thanks

     

    M



  • 18.  RE: Having weird DNS issues since update to firmware 6.4.2.6-4.1.1.9_51442

    Posted Sep 21, 2015 05:11 PM
    What version of IAP was that?


  • 19.  RE: Having weird DNS issues since update to firmware 6.4.2.6-4.1.1.9_51442

    Posted Sep 21, 2015 05:14 PM

    it is a 205



  • 20.  RE: Having weird DNS issues since update to firmware 6.4.2.6-4.1.1.9_51442

    Posted Sep 21, 2015 05:21 PM

    To go back to the firmware you had before you upgraded:

     

     

    1. This works only in same AP type cluster.

    2. Make only one AP as preferred master.

    3. Do switch-action-reboot command from Virtual Controller's cli.

     

    Please see the article here:  http://community.arubanetworks.com/t5/Controller-less-WLANs/How-to-change-the-boot-partition-of-Instant-and-perform-an/ta-p/234166 for more detail

     

     

     



  • 21.  RE: Having weird DNS issues since update to firmware 6.4.2.6-4.1.1.9_51442

    Posted Sep 22, 2015 01:17 PM

    FYI... I am happy to announce that I just got confirmation that Aruba pulled this buggy firmware from distribution. This will save a lot of people unnecessary frustration! I am glad that they responded to our requests.



  • 22.  RE: Having weird DNS issues since update to firmware 6.4.2.6-4.1.1.9_51442

    Posted Oct 07, 2015 09:15 PM

    This issue has been fixed in 4.1.1.10



  • 23.  RE: Having weird DNS issues since update to firmware 6.4.2.6-4.1.1.9_51442

    Posted Sep 17, 2015 04:13 PM

    @rmedeiros wrote:

    We have 81 Aruba 225 IAP's in a cluster. We have a VLAN setup for our wireless traffic and our wired traffic runs on a different VLAN. Before I updated our firmware to version  6.4.2.6-4.1.1.9_51442, everything worked fine, but now I am unable to resolve DNS in our reverse lookup zone, forward lookup works fine. Here is the kicker... if I cable the PC in, everything works fine. Our VLANS are routed on a layer 3 switch, no filtering or anything, it just routes all traffic between VLAN's. Everything else works fine: Internet, Forward DNS lookup, ping, etc... any ideas???


    rmedeiros,

     

    You will have to downgrade to avoid the issue we are investigating.  Please PM me if you need a specific version of code to downgrade your IAP 225 to..

     



  • 24.  RE: Having weird DNS issues since update to firmware 6.4.2.6-4.1.1.9_51442

    Posted Oct 07, 2015 06:38 PM

    This should probably be stickied so people see it. I had to dig for it unfortunately. We've been having reverse DNS issues on wifi for over a week now and havent had time to look into it. Finally it impacted a PoC we were doing and it needs to be resolved ASAP. I sent a PM to you cjoseph, thanks for the help.