Controllerless Networks

last person joined: yesterday 

Aruba Instant Wi-Fi: Meet the controllerless Wi-Fi solution that's easy to set-up, is loaded with security and smarts, and won't break your budget.
Expand all | Collapse all

DNS response code 5: refused , for wireless users

This thread has been viewed 0 times
  • 1.  DNS response code 5: refused , for wireless users

    Posted Jun 03, 2016 07:24 AM
      |   view attached

    Hey All,

    Facing issue with wireless users. Domain lookup is not happening for them, thus causing no internet.

    We configured IAP internal DHCP server along with google public DNS. Users are getting correct IP and able to ping 8.8.8.8  but not able to resolve the domain name.

    When I am connecting to the wired port with same IP configuration I am able to do #nslookup with success.

    I have done dns debug for the users and its saying "response code: refused(5)" , nothing is blocking in Firewall.

    Attached is the log file.

     

    Attachment(s)



  • 2.  RE: DNS response code 5: refused , for wireless users



  • 3.  RE: DNS response code 5: refused , for wireless users

    Posted Jun 03, 2016 08:06 AM
    Nope,Its not configured.


  • 4.  RE: DNS response code 5: refused , for wireless users

    EMPLOYEE
    Posted Jun 03, 2016 08:12 AM

    Do you have a toplogy diagram?

    How are these users getting to the internet?

    What is the client default gateway?

    We are missing detail here.



  • 5.  RE: DNS response code 5: refused , for wireless users

    Posted Jun 03, 2016 08:15 AM
    IAP > L2 sw > L3 sw > Firewall.
    Firewall is the gateway for the client.


  • 6.  RE: DNS response code 5: refused , for wireless users

    Posted Jun 08, 2016 09:21 AM

    Hi SumaN,

     

    Please configure the same DNS server for the IAP as well & then test the client connectivity.



  • 7.  RE: DNS response code 5: refused , for wireless users

    Posted Jun 13, 2016 04:07 AM

    Hi SumaN,

    IAP proxies all DNS requests for the clients in this mode.

     

    If you configure an asterisk (*) instead of a domain name in the enterprise domain list, all DNS requests areforwarded to the default DNS server of the client. If you want all DNS requests to be processed by the DNS server of the client, configure an asterisk (*) in the enterprise domain setting.

     

    So, we have the following options:

     

    1. Configure the DNS server to be same for IAP & Client.

    2. In case we do not have DNS configured for the IAP, then configure an asterisk (*) in the enterprise

    domain settings which will allow all the DNS request to be processed by the DNS server of the client.



  • 8.  RE: DNS response code 5: refused , for wireless users

    Posted Jun 30, 2016 12:43 AM
    Thanks Nitesh,
    I configured '*' under enterprise domain and it started to work.


  • 9.  RE: DNS response code 5: refused , for wireless users

    Posted Jul 20, 2016 06:27 AM

    Hi SumaN,

     

    Thank you for confirming that things are workin as expected.