Wireless Access

last person joined: 6 hours ago 

Access network design for branch, remote, outdoor and campus locations with Aruba access points, and mobility controllers.

Creating a second local DHCP scope for Instant in Airwave

  • 1.  Creating a second local DHCP scope for Instant in Airwave

    Posted Oct 03, 2019 06:22 PM

    Hello,

    I'm trying to create a new DHCP scope in Airwave for our Instant APs without much success. Well, I'm able to set it up, but it isn't assigning IP addresses. The same AP cluster is working fine for two other WLANs, an enterprise network and a guest network. 

     

    Here's the config on the VC after setting it up in Airwave:

     

    ip dhcp Extended-Learning
    server-type Local
    server-vlan 35
    subnet 192.168.98.0
    subnet-mask 255.255.255.0
    exclude-address 192.168.98.0 192.168.98.20
    lease-time 86400
    dns-server 8.8.8.8,8.8.8.4
    domain-name Ext-Learn

    This corresponds to a WLAN for this program:

     

    wlan ssid-profile SBUSD-EL
    enable
    index 2
    zone 99
    type guest
    essid SBUSD-EL
    utf8
    wpa-passphrase bf4b1a72101a11371303afeba91649ed4461c16c113d9b22
    opmode wpa2-psk-aes
    max-authentication-failures 0
    vlan 35
    rf-band all
    captive-portal disable
    dtim-period 1
    broadcast-filter none
    dmo-channel-utilization-threshold 90
    local-probe-req-thresh 0
    max-clients-threshold 64

    With the following ACLs:

     

    wlan access-rule SBUSD-EL
    utf8
    index 4
    rule any any match any any any permit
    rule any any match udp 67 68 permit
    rule any any match udp 53 53 permit
    rule 10.0.0.0 255.0.0.0 match any any any deny
    rule 172.16.0.0 255.240.0.0 match any any any deny
    rule 8.8.8.8 255.255.255.255 match udp 53 53 permit
    rule 8.8.8.4 255.255.255.255 match udp 53 53 permit
    rule any any match tcp 80 80 permit
    rule any any match tcp 443 443 permit

    Showing the DHCP Allocation:

     

    IB-OFFICE_d9:0e# sh dhcp-allocation

    ---------------------/etc/dnsmasq.conf--------------------
    listen-address=127.0.0.1
    addn-hosts=/etc/ld_eth_hosts
    addn-hosts=/etc/ld_ppp_hosts
    dhcp-src=192.168.99.1
    dhcp-leasefile=/tmp/dnsmasq.leases
    dhcp-authoritative
    filterwin2k
    #magic-vlan
    {
    vlan-id=3333
    dhcp-range=192.168.99.3,192.168.99.254,255.255.255.0,1440m
    dhcp-option=1,255.255.255.0
    dhcp-option=3,192.168.99.1
    dhcp-option=6,8.8.8.8,8.8.8.4
    dhcp-option=54,192.168.99.1
    dhcp-option=15,Guest
    }
    #profile: Extended-Learning
    {
    vlan-id=35
    dhcp-range=192.168.98.22,192.168.98.254,255.255.255.0,86400s
    dhcp-option=1,255.255.255.0
    dhcp-option=3,192.168.98.21
    dhcp-option=6,8.8.8.8,8.8.8.4
    dhcp-option=15,Ext-Learn
    }
    ---------------------/tmp/dnsmasq.leases------------------
    115736 2c:0e:3d:83:4f:07 192.168.99.130 3333 Queenofcad-S7 01:2c:0e:3d:83:4f:07

    IB-OFFICE_d9:0e#

     

    and displaying the dhcp database shows:

     

    IB-OFFICE_d9:0e# sh ip dhcp database

    DHCP Subnet :192.168.99.0
    DHCP Netmask :255.255.255.0
    DHCP Lease Time(m) :1440
    DHCP Domain Name :Guest
    DHCP DNS Server :8.8.8.8,8.8.8.4
    DHCP DNS Cache :Disabled

     

    Shouldn't I see both scopes here? All I'm getting on the client side is an APIPA address and no connectivity. Any ideas what I'm missing? I've rebooted the cluster with no luck.

     

    Thanks!
    Mark