Security

last person joined: 13 hours ago 

Enterprise security using ClearPass Policy Management, ClearPass Security Exchange, IntroSpect, VIA, 360 Security Exchange, Extensions and Policy Enforcement Firewall (PEF).
Expand all | Collapse all

OSX Clearpss captive portal not closing

This thread has been viewed 0 times
  • 1.  OSX Clearpss captive portal not closing

    Posted Jan 24, 2020 04:17 AM
      |   view attached

    Hi All,

     

    I have created a captive portal in clearpass which is working great, the user enters their username and password ( and 2fa token as i have linked it  to a radius server) and then login in fine, and get redirect to the "you have successfully login in " but the captive portal does not auto close, there is no close button, you just have to press cancel or the X

     

    see attached, which shows after i have successfully logged in. I am connecting to a network that does not have Internet access ( if that make a difference ) 

     

    Any suggestions 

     

    Thanks

     



  • 2.  RE: OSX Clearpss captive portal not closing

    Posted Jan 24, 2020 04:56 AM

    Hi,

     

    Answering your query.

     

    You can use the destination URL option to handle this and redirect the authenticated user to your website webpage.

     

    destination.JPG

    also i did not understood your last line " I network connecting from and two does not have Internet access ( if that make a difference ) "

     

     



  • 3.  RE: OSX Clearpss captive portal not closing

    Posted Jan 24, 2020 05:01 AM

    Not had more morning coffee yet, i have updated the last line

     

    In terms of the redirect, that is working fine, and i get redirect without an issue ( that is what the attached image was showing) but the OSX captive portal still shows cancelled as the option not closed. 

    i



  • 4.  RE: OSX Clearpss captive portal not closing

    Posted Jan 24, 2020 06:13 AM

    Hi,

     

    I have few questions for you.

     

    • Is it possible to Post a short video here explaining the work-flow and the place where OSX device is getting stuck.
    • Is it happening with only OSX devices?
    • What is the NAD device(Controller) which is serving the clients for Guest SSID.
    • Is this issue is specific to any browser, have you tested on different browsers like Chrome, Safari, Firefox.