Security

last person joined: 8 hours ago 

Enterprise security using ClearPass Policy Management, ClearPass Security Exchange, IntroSpect, VIA, 360 Security Exchange, Extensions and Policy Enforcement Firewall (PEF).
Expand all | Collapse all

ClearPass Guest SMTP to SMS delivery problems

  • 1.  ClearPass Guest SMTP to SMS delivery problems

    Posted Apr 11, 2013 04:04 AM

    Hello,

     

    I am trying to get SMS delivery to work through our company's internal SMTP to SMS gateway using ClearPass Guest 6.0.2.23328

     

    Our SMTP to SMS gateway uses the following syntax for sending messages: SMS/NUMBER@smsgate.ourdomain.de

     

    Since I couldn't get anything to work I set up a monitoring session on the SMS gateway's LAN port using Wireshark.

     

    It seems ClearPass Guest is not sending any data using the SMTP protocol even though the application log says it does:

     

    Client: 172.20.100.30:56845
    App User: netadmin
    Script: /guest/sms_processors.php
    Function: NwaSmsSendMessage
    Arguments: array (
    'rtn' => array (
    'error' => 0,
    'message' => 'Message sent',
    ),
    'args' => array (
    '_ajax_mode' => 'submit',
    'title' => 'Send SMS',
    'handler' => 10,
    'hide_processor' => true,
    'do_cancel' => '1',
    'no_handler' => 'No gateways exist: <span class="nwaIconLink" style="display: inline-block;" title="Create new SMS gateway"><a href="sms_processor_edit.php"><img src="images/icon-sms22.png" style="vertical-align: middle;" alt="" align="absmiddle" border="0" height="22" width="22"></a>&nbsp;<a href="sms_processor_edit.php">Create new SMS gateway</a></span>',
    'message' => 'test10',
    'recipient' => '+491715552255',
    'carrier' => NULL,
    ),
    )

     

    I have specified a custom SMTP to SMS carrier for our SMS gateway using the term "SMS/" as its "country code".

     

    I am at a loss here... any help is appreciated!

     

    Thanks!



  • 2.  RE: ClearPass Guest SMTP to SMS delivery problems

    Posted Apr 11, 2013 08:19 PM

    You have confirmed a normal email test works, yes?  Also, make sure you are on the latest version of 6.0.2 as an updated was made concerning setting up a carrier such as yours.  If you are on it, when you edit the carrier the SMS Template description should be:

    "Enter an example email address.
    Use the keyword ‘NUMBER’ where appropriate, otherwise everything after the ‘@’ will be used."

     

    So in your case you would enter it exactly as you did above: "SMS/NUMBER@smsgate.ourdomain.de".  You would want to leave all the prefix and country code stuff alone or back to its defaults.  Your number 491715552255 would then result in an email to "SMS/491715552255@smsgate.ourdomain.de".  Does that look like what you want?

     

    How are you setting the carrier option?  Via visitor_carrier, or do you have your entry hard coded into the SMS over SMTP setup?

     

    You can try enabling debug mode in the SMS gateway setup and the log will give more details on the email and message. 

     

    As for Wireshark, do you have multiple interfaces enabled?  Are you sure the route to your SMTP server is correct?