Controllerless Networks

last person joined: 10 hours ago 

Aruba Instant Wi-Fi: Meet the controllerless Wi-Fi solution that's easy to set-up, is loaded with security and smarts, and won't break your budget.
Expand all | Collapse all

Webgui of IAP 105 won't load

Jump to Best Answer
  • 1.  Webgui of IAP 105 won't load

    Posted Apr 28, 2016 04:50 PM

    Hello,

     

    For about a year I've been running 6 Aruba 105's in my network. Since the initial install they have been working flawlessly. Because of that I haven't accessed the Virtual Controller via the webgui for about half a year now. 

     

    This evening I figured I checked the webgui again. Unfortunately I'm not able to login anymore. After entering the correct address in my browser, I get presented with the login screen of the VC. However, after providing the correct credential, the webgui begins to load but within a second I return to the login page again without an error showing on screen.

     

    Strange thing is that I am able to login to the VC using SSH, so credentials must be correct. 

     

    Elsewhere on this forum I found someone having the same issue, but this issue was solved by configuring the correct date/time on the VC via CLI. I've checked this on mine an both date and time are exactly the same as on the pc I access the VC from.

     

    Also rebooting the IPA didn't do the trick.

     

    Any ideas on how to troubleshoot/solve this?

     

    Thanks!



  • 2.  RE: Webgui of IAP 105 won't load

    Posted Apr 28, 2016 05:53 PM

     Hi Dekam,

     

    something similar happened to me a year ago. It was not working with Safari, IE or Firefox, but it was working with Chrome. 

     

    Have you tried different browsers?

    Regards

    Borja



  • 3.  RE: Webgui of IAP 105 won't load

    Posted Apr 28, 2016 05:59 PM

    Hi Borja,

     

    Yes I tried them all (Chrome, Firefox, Firefox Portalbe, IE (different versions), Safari, Edge). Result is exactly the same in all browsers. Login screen loads, webgui is displayed for about 1 second, then disappears and I'm presented with the login screen again.

     

    Aruba OS version is 6.4.2.0-4.1.1 by the way.

     



  • 4.  RE: Webgui of IAP 105 won't load
    Best Answer

    Posted Apr 28, 2016 06:46 PM

    Hi Dekam,

     

    have a look onto this thread: http://community.arubanetworks.com/t5/Aruba-Instant-Cloud-Wi-Fi/IAP-115-Virtual-Controller-Issues/td-p/158918

     

    Apparently they had the same issue and when they disconnected the master, they were able to access the UI again. However, the version of code was older than yours.

     

    Regards

    Borja

     



  • 5.  RE: Webgui of IAP 105 won't load

    Posted Apr 29, 2016 05:26 AM

    Hi Borja,

     

    Although the situation described in the topic you mentioned was indeed not exactly the same, it did point me to a solution for my issue. 

     

    Since I monitor the network remotely, I had configured a port-forwarding rule in the router. This rule made sure that port 4343 was forwarde to the IP-address of the master IAP. Based on the topic you pointed me to, I used the CLI to dig a bit deeper and discovered that somehow another master IAP (different IP-address) was appointed and that I was effectively trying to login to a slave IAP. 

     

    After changing the forwarding rule to make sure it was explicitely pointing to the IP-address of the master, the webGUI worked again.

     

    I still don't understand why it is apparently critical to point to the actual master IAP (as far as I understood all the slave IAPs should forward request to the master IAP) but at least it solved my issue for now.

     

    Thanks!