Network Management

last person joined: 5 hours ago 

Keep an informative eye on your network with IMC and Airwave network management solutions.
Expand all | Collapse all

HPE switches and AIrwave

Jump to Best Answer
  • 1.  HPE switches and AIrwave

    Posted Feb 23, 2016 08:16 AM

    In the latest software 16.01 for 2530 switches, there is a command for adding Airwave support to the switch:

     

    amp-server ip <AMP server IP address> group 2530 folder 2530 secret secret

     

    Has anyone gotten this to work? I have run this command on several 2530 switches, and they do not show up in Airwave. The switch log show these entries:

     

    I 02/23/16 13:17:46 05103 dhcp: Device Registration to Airwave failed
    I 02/23/16 13:17:46 05101 dhcp: Airwave details configured.

     



  • 2.  RE: HPE switches and AIrwave

    Posted Feb 23, 2016 08:18 AM
    You need to add them in AirWave. 

    Sent from Nine


  • 3.  RE: HPE switches and AIrwave

    Posted Feb 23, 2016 08:37 AM

    OK, I have done that, but the same message keep appearing in the switch log:

     

    I 02/23/16 14:29:47 05103 dhcp: Device Registration to Airwave failed
    I 02/23/16 14:28:47 05103 dhcp: Device Registration to Airwave failed
    I 02/23/16 14:27:47 05103 dhcp: Device Registration to Airwave failed
    I 02/23/16 14:26:47 05103 dhcp: Device Registration to Airwave failed
    I 02/23/16 13:26:46 05103 dhcp: Airwave Registration failed.

     

    And what can I do with these switches now in Airwave that was not possible before? According to the release notes Airwave now supports ZTP of former Procurve switches. Does that mean that I can push AW group config and overrides to them like with MAS? Do firmware upgrades? Detect config mismatches?

     



  • 4.  RE: HPE switches and AIrwave

    Posted Feb 24, 2016 11:33 AM

    Checking with the QA tester.  In the meantime, what AMP version are you running?



  • 5.  RE: HPE switches and AIrwave

    Posted Feb 25, 2016 03:01 AM

    8.0.11



  • 6.  RE: HPE switches and AIrwave
    Best Answer

    Posted Feb 25, 2016 06:17 PM

    Looks like your version of AirWave doesn't have the newly added HPE switch support.  HPE switch support for that firmware is in AirWave 8.2 (currently in BETA testing stage).  Approximation for AirWave 8.2 release would be March/April timeframe.



  • 7.  RE: HPE switches and AIrwave

    Posted Feb 26, 2016 02:43 AM

    Thank you, Rob.



  • 8.  RE: HPE switches and AIrwave

    Posted May 31, 2017 01:04 PM

    I'm running airwave 8.2.x, which does support the HPE Aruba switches and I still can't get them to import.  Pretty sure my options in DHCP are correct, and amp-server config on the switch is correct.  Looking for ideas.

     

    Thanks



  • 9.  RE: HPE switches and AIrwave

    Posted Jun 01, 2017 04:24 AM

    Hi Jeremy,

     

    May I know switch model/firmrware version ? How you are adding the device to Airwave?

     

    We could add the device manually/discovery method/CSV file/Aruba Activate . Have you tried manually adding the device from Devices Setup > Add page.

     

    configure snmp conmmunity string first in switch and go to Airwave Device setup page and add the device manually and check the status.

     

    Regards,

    Pavan

     

    If my post addresses your query give kudos:)



  • 10.  RE: HPE switches and AIrwave

    Posted Jun 01, 2017 12:11 PM

    Hi Pavan,

     

    HPE 2920 (J9727A) switch running 16.03 code.

     

    I'll try adding manually.  Would the model indicated fall under the HPE Aruba Switch device, or does it require setup of a new device?

     

    Thanks



  • 11.  RE: HPE switches and AIrwave

    Posted Jun 01, 2017 12:50 PM

    Hi ,

     

    Try add it as HPE switch, in drop down list we have option to select as HPE.

     

    Regards,

    Pavan



  • 12.  RE: HPE switches and AIrwave

    Posted Aug 31, 2018 07:17 AM

    Hello!

     

    I would like to ask a related question. I am running AMP 8.2.7 and I want to manage an Aruba 2930F switch with WC.16.05.0007 version. I have set the following command on the switch (like the first person said):

    amp-server ip <AMP server IP address> group aruba_switches folder aruba_switches secret secret

     

    Then I added the switch manually under Device setup->add. I added it as Aruba device. Then I set the IP adress of the switch and the host name. In the community string I typed the "secret".

     

    Then my switch comes up in down state, and has a "Status: Down (SNMP get failed) ".

     

    Also getting the following log in the switch:

    I 08/31/18 13:13:46 05103 amp-server: Default, Primary or Management VLAN is not configured with IP or DHCP.
    W 08/31/18 13:13:38 00236 snmp: Security access violation from <AMP server IP address> for the community name or user name : secret (8 times in 60 seconds)

     

    What am I missing?

     

    I also tried to create snmpv3 user and setting that in the "manage" tab, but with no luck.

     

    The only way I could get the switch to communicate with AMP is when I do a ZTP with Activate. Then the switch comes up to AMP, but when I change the IP adress to static (because it has a DHCP IP because of the ZTP) then the switch stops communicating and gives me a Status: Down (SNMP get failed) message again.

     

    If someone has any idea please share.

     

    Daniel



  • 13.  RE: HPE switches and AIrwave

    Posted Aug 31, 2018 07:24 AM

    And on more thing, if I add it as custom device, it immediately comes up as "UP" in AMP.

     

    So I am thinking it is not coming up because a wrong device selection, but I didn't find any "aruba switch" selection when I add it manually. I also tried adding it as HPE type switch but failed.

     

    Daniel



  • 14.  RE: HPE switches and AIrwave

    Posted Aug 31, 2018 12:31 PM

    I see you're trying to do SNMPv3 -> make sure the Group - select group - Basic tab is set to use SNMPv3 to communicate with the device.

     

    Also, make use of this guide for testing SNMP communication



  • 15.  RE: HPE switches and AIrwave

    Posted Feb 24, 2019 10:03 AM

    Hi,

     

    Did you by any chance try the following command (on the switch):

     

    snmp-server response-source dst-ip-of-request

     

    Better late than never!

     

    Kindly share the solution if you have already found it!



  • 16.  RE: HPE switches and AIrwave

    Posted Sep 11, 2019 10:42 AM

    For me, to solved the "Default, Primary or Management VLAN is not configured with IP or DHCP." problem. I had to change my primary vlan from the default of 1 to 253 because we use 253 for our switch management IP. The command was: primary-vlan 253

     

    Then the debug ztp output showed:

     

    0000:00:38:57.68 ZTP mairwaveCtrl:Received message 0x910001
    0000:00:38:57.68 ZTP mairwaveCtrl:Default, Primary or Management VLAN is configured with IP or DHCP
    0000:00:38:57.68 ZTP mairwaveCtrl:AMP server registration started.
    0000:00:38:57.68 ZTP mairwaveCtrl:IPSEC ZTP: No amp type vpn, Check-in to Airwave
    0000:00:38:57.68 ZTP mairwaveCtrl:sending request to  https://192.168.10.167/switch_https
    0000:00:38:57.68 ZTP mairwaveCtrl:Added X-Type: Device-Reg
    0000:00:38:57.68 ZTP mairwaveCtrl:Added X-OEM: HP
    0000:00:38:57.68 ZTP mairwaveCtrl:Added X-Mode: SWITCH
    0000:00:38:57.68 ZTP mairwaveCtrl:Added X-Current-Version: WC.16.09.0004_786
    0000:00:38:57.68 ZTP mairwaveCtrl:Added X-Device-Info: TW94HKZ2LL,
    38:21:C7:BA:5C:F0, 2930F-8G-PoE+-2SFP+ Switch
    0000:00:38:57.68 ZTP mairwaveCtrl:Added X-Group: Kitchener
    0000:00:38:57.68 ZTP mairwaveCtrl:Added X-Folder: Kitchener
    0000:00:38:57.68 ZTP mairwaveCtrl:Added X-Shared-Secret: d2l-kit-switches
    0000:00:38:57.68 ZTP mairwaveCtrl:Added X-Device-State: Non-factory
    0000:00:38:59.53 ZTP mairwaveCtrl:Switch registered Sucessfully 0 - HTTP/1.1 200 OK

     

    Cheers, Mark W.