Aruba Central

 View Only
last person joined: 2 days ago 

Expand all | Collapse all

Switch won't connect back to central without a reboot

This thread has been viewed 26 times
  • 1.  Switch won't connect back to central without a reboot

    Posted Mar 22, 2022 01:34 PM
    Curious if anyone knows a way to have a 2930f switch reconnect to central without a reboot. We have several switches that seem to do this for some reason.  They are being managed in central in groups and everything seems to work fine until we have a brief internet outage.  Sometimes they will reconnect automatically and other times, we have to power cycle the switch in order to reconnect with central.  The command show aruba-central shows "TCP timeout. Server is taking longer time to respond. Check the server reachability."  The switch log shows "Received failure response from the Activate server with status code: fail-prov-no-rule".  I would like to re-establish connection with central without a reboot if possible. Thanks!

    ------------------------------
    Michael King
    ------------------------------


  • 2.  RE: Switch won't connect back to central without a reboot

    MVP GURU
    Posted Mar 24, 2022 07:39 AM
    Try running the "activate provision force" command at the exec level (#). You can check the status with "show activate provision" and also check the status of the central connection with "show aruba-central"

    ------------------------------
    Dustin Burns

    Lead Mobility Engineer @Worldcom Exchange, Inc.

    ACCX 1271| ACMX 509| ACSP | ACDA | MVP Guru 2022
    If my post was useful accept solution and/or give kudos
    ------------------------------



  • 3.  RE: Switch won't connect back to central without a reboot

    Posted Mar 24, 2022 08:36 AM
    Thanks for the reply.  I've tried that and still not working. The output from the switch is below.  It is in a group with multiple other switches and, if I restart it, it will normally connect to central at bootup.  Everything I've read says that error means it is not in a folder with a provisioning rule but I would think if that were the case, it wouldn't connect after a reboot.  
      
    show aruba-central

    Configuration and Status - Aruba Central

    Server URL : https://device-prod2.central.arubanetworks.com/ws
    Connected : No
    Mode : NA
    Last Disconnect Time : Thu Mar 17 09:30:01 2022
    Server DNS Lookup : Success
    Proxy Server DNS Lookup : NA
    Error Reason : TCP timeout. Server is taking longer time to
    respond. Check the server reachability.

    show activate provision

    Configuration and Status - Activate Provision Service

    Activate Provision Service : Enabled
    Activate Server Address : devices-v2.arubanetworks.com
    Activation Key : ERTSSI8S
    Time Sync Status : Time sync from SNTP server
    Activate DNS Lookup : Success
    Proxy Server DNS Lookup : NA
    Activate Connection Status : Failure
    Error Reason : Activate provision has failed because of
    invalid response received from server with status code : fail-prov-no-rule
    Override Default Config Check : Disabled


    ------------------------------
    Michael King
    ------------------------------



  • 4.  RE: Switch won't connect back to central without a reboot

    MVP GURU
    Posted Mar 24, 2022 08:58 AM
    I would open a TAC ticket to figure this one out.

    ------------------------------
    Dustin Burns

    Lead Mobility Engineer @Worldcom Exchange, Inc.

    ACCX 1271| ACMX 509| ACSP | ACDA | MVP Guru 2022
    If my post was useful accept solution and/or give kudos
    ------------------------------



  • 5.  RE: Switch won't connect back to central without a reboot

    Posted Mar 24, 2022 10:54 AM
    Yeah, I'll go ahead and do that.  Thanks for the help!

    ------------------------------
    Michael King
    ------------------------------



  • 6.  RE: Switch won't connect back to central without a reboot

    Posted Mar 24, 2022 11:04 AM
    I went ahead and rebooted the switch.  Just thought I would post the results after the reboot.  It immediately connected to central and is in sync.

    show aruba-central

    Configuration and Status - Aruba Central

    Server URL : https://device-prod2.central.arubanetworks.com/ws
    Connected : Yes
    Mode : Managed
    Last Disconnect Time : NA
    Server DNS Lookup : Success
    Proxy Server DNS Lookup : NA
    Error Reason : NA


    show activate provision

    Configuration and Status - Activate Provision Service

    Activate Provision Service : Enabled
    Activate Server Address : devices-v2.arubanetworks.com
    Activation Key : Not Available
    Time Sync Status : Time sync from NTP pool
    Activate DNS Lookup : NA
    Proxy Server DNS Lookup : NA
    Activate Connection Status : NA
    Error Reason : NA
    Override Default Config Check : Disabled

    ------------------------------
    Michael King
    ------------------------------



  • 7.  RE: Switch won't connect back to central without a reboot

    Posted Mar 24, 2022 04:09 PM
    Just thought I would post a resolution.  I opened a TAC case and the resolution was to execute commands from CLI -  aruba-central disable and then aruba-central enable - which connects the switch back to central.

    ------------------------------
    Michael King
    ------------------------------