Controllerless Networks

last person joined: yesterday 

Aruba Instant Wi-Fi: Meet the controllerless Wi-Fi solution that's easy to set-up, is loaded with security and smarts, and won't break your budget.
Expand all | Collapse all

IAP- Make port ENET1 the default Uplink port

This thread has been viewed 23 times
  • 1.  IAP- Make port ENET1 the default Uplink port

    Posted Apr 07, 2021 12:57 PM
    Hi guys!

    The super shortened version is:
    Is there a way to make ENET1 truly as the default port so the ENET0 don't mess in the booting process and let the AP discover the network on time using ENET1?

    Here's the long version:

    Here's my issue.
    Long time ago an IAP-325 got wet and the ENET0 port got damaged, but we changed the patchcord to port ENET1 and the AP received PoE, was powered on, working properly and everything was ok. This AP was under a 7005 controller.

    Recently we took this AP and reset it to work in Instant mode. As I factory-default the AP, now the ENET1 is disabled by default and can no longer join to a network.
    I accessed by console port and assign ENET1 port to a wired profile,
    The wired profile looks like this:
    wired-port-profile Uplink
    switchport-mode trunk
    allowed-vlan all
    native-vlan 1
    no shutdown
    access-rule-name Uplink
    speed auto
    duplex auto
    no poe
    type employee
    captive-portal disable
    no dot1x

    #####  In this line I assigned the port to a wired profile
    enet1-port-profile Uplink

    Basically I just enabled 'Uplink' option, make admin 'UP', Trusted and assign it to ENET1.
    After I did this, the port went up received an IP address and was able to work "correctly" but only as a master.

    The problem was when I tried the AP to join to an existing cluster.
    The console info shows that it first tries to use ENET0 as uplink but it fails (it's damaged), after a few tries it changes to ENET1 and continues the boot up process.
    Ethernet uplink eth0 not active yet
    Ethernet uplink eth0 not active yet
    skip backup uplink detect, as not dual uplink or no bonding
    ethx uplink enabled. Becoming Mesh Portal
    Mesh is DISABLED on this device.
    extended ssid is activated o[ 136.136832] bonding: bond0: enslaving eth1 as a backup interface with a down link.
    n the platform ...
    copying bootuplog ...
    [ 136.314589] uol: module license 'Proprietary' taints kernel.
    [ 136.398844] Disabling lock debugging due to kernel taint
    [ 136.463105] UOL ctf init done
    [ 136.497813] uol_hw_offload_enable:925 enable=1
    [ 136.550952] uol_set_cfg:856 cfg update: 0x140->0x143
    [ 136.612714] UOL nss init done
    [ 136.645735] init_uol_mod: offload cap: 0x143, mesh mode none, strapless_enabled 0, uplink_vlan 0 wifi_uplink 0
    [ 136.791658] eth1: 100 Mbps Full Duplex
    [ 136.831771] bonding: bond0: link status definitely up for interface eth1, 100 Mbps full duplex.
    [ 136.928209] bonding: bond0: making interface eth1 the new active one.
    [ 137.005654] AP xml model 89, num_radios 2 (jiffies 68499)
    [ 137.069853] apType 89 hw_opmode 0
    [ 137.109528] radio 0: band 1 ant 0 max_ssid 16
    [ 137.161512] radio 1: band 0 ant 0 max_ssid 16
    [ 137.161761] bonding: bond0: first active interface up!
    [ 137.161824] ADDRCONF(NETDEV_CHANGE): bond0: link becomes ready
    [ 137.345235] init_asap_mod: installation:0
    [ 137.392783] election init: rand=14 HZ=500
    [ 137.440768] IAP client match init
    [ 137.480318] ethernet_device_event: dev eth0 is up
    [ 137.536644] ethernet_device_event: dev eth1 is up
    [ 138.071915] anul_radio_bond_sysctl_init

    Somewhere in the booting process the port changes to ENET0 again, use a default IP and then makes the election. Since there's nothing in the ENET0 the IAP thinks he's all alone and makes himself the Master AP.
    [ 216.227147] asap_user_update_stm_bridge_user : Stack IP is 0
    [ 218.436863] Default IP is ready!
    [ 222.613620] ip_time_handler: Got ip and packets on bond0 Started master election 1-0, rand 24

    User: [ 246.789628] i am master now
    [ 246.810527] (10:50:43) !!! Init ---> Master
    [ 246.860512] asap_send_elected_master: sent successfully

    After some minutes the ENET1 goes active again, and the AP notices that there's an existing cluster.
    ble_ready is present @340 .... start processing msgs from APB     In this part is when the ENET1 responds pings again.
    [ 337.710059] (10:52:14) OOPS. someone else thinks he is the master too, beacon version 4 from 00:0b:86:f5:cf:e2 eth1
    [ 337.834145] (10:52:14) I am MASTER. recv-ed a master normal-beacon.
    [ 337.909059] (10:52:14) master provision, 0 vs. 0
    [ 337.964261] (10:52:14) !!! Election result, -5
    [ 339.475007] bonding: bond0: releasing backup interface eth0
    [ 339.529240] bonding: bond0: Warning: clearing HW address of bond0 while it still has VLANs.
    [ 339.629209] bonding: bond0: When re-adding slaves, make sure the bond's HW address matches its VLANs'.
    [ 339.741143] ethernet_device_event: dev eth0 others: 9
    [ 339.802186] ethernet_device_event: dev eth0 is down
    [ 339.860293] ethernet_device_event: dev eth0 others: 8
    [ 339.926491] ethernet_device_event: dev eth0 others: 13
    [ 339.981943] ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ 340.044923] ethernet_device_event: dev eth0 is up
    [ 340.119025] ethernet_device_event: dev eth1 others: 9
    [ 340.168228] ethernet_device_event: dev eth1 is down
    [ 340.225835] ethernet_device_event: dev eth1 others: 20
    [ 340.287035] ethernet_device_event: dev eth1 others: 8
    [ 340.347516] ethernet_device_event: dev eth1 others: 13
    [ 340.409153] ethernet_device_event: dev eth1 is up
    [ 340.467197] bonding: bond0: enslaving eth1 as a backup interface with a down link.
    [ 340.923805] ethernet_device_event: dev eth1 is changed, carrier: 0

    After this, the AP restarts again and the whole process repeats itself, on an on.

    So, when the AP is alone without any other IAPs in the network, it takes some minutes to take ENET1 up and works fine.
    But, when the AP is in an existing cluster network, it makes the master election when the port is not ready, after it gets ENET1 ready it notices another AP as master and reboots itself.

    So basically I can't get the AP to work as Instant with other APs using ENET1 as uplink.

    Is there a way to make ENET1 truly as the default port so the ENET0 don't mess in the booting process and let the AP discover the network on time?

    I really appreciate in taking your time reading the whole thing.
    Best regards!   \m/

    Javier Valdes

  • 2.  RE: IAP- Make port ENET1 the default Uplink port

    Posted Apr 08, 2021 03:22 AM


    I guess the command you are missing is:

    preferred-uplink <0,1>

    just check this URL to read more about it


    Jochem Knoben

  • 3.  RE: IAP- Make port ENET1 the default Uplink port

    Posted Apr 08, 2021 05:27 PM
    Hi Jochem,

    Thanks for your reply. I tried that command but I got the following message: AP platform Octomore doesn't support preferred uplink. Maybe it works only in  the models IAP-318 and 370 series as mentioned in the guide.

    But following also that guide I tried the 'enforcement' option and setting up a higher priority on port Eth1, but didn't solve the issue, the booting process it's pretty much the same as described before.


    Javier Valdes

  • 4.  RE: IAP- Make port ENET1 the default Uplink port

    Posted Apr 09, 2021 04:22 AM

    Hi Javier,

    checking the ​"ArubaInstant 8.x Command-Line Interface reference guide":

    there you do find no such restriction - regarding platforms "all" are mentioned for the "preferred-uplink".

    Thus I do suggest to open a TAC-Case (if they can't provide a fix for the issue itself they should replace the AP as Workaround)


    Jochem Knoben

  • 5.  RE: IAP- Make port ENET1 the default Uplink port

    Posted Apr 09, 2021 02:09 PM
    Hi Jochem,

    You're right, it doesn't specify any restriction on a specific platform. 
    One thing I do not know is if I need to change the hierarchy level on CLI. I only logged in via console port, enter 'configure terminal' and try the command "preferred-uplink 1".
    But since that command is per AP, and the login session is to the virtual controller, I don't know if I need to change the prompt to an AP-level, if that can be done, and if it is, how would I do that?


    Javier Valdes