Wired

last person joined: yesterday 

Bring performance and reliability to your network with the Aruba Core, Aggregation, and Access layer switches. Discuss the latest features and functionality of the ArubaOS-Switch and ArubaOS-CX devices, and find ways to improve security across your network to bring together a mobile first solution.
Expand all | Collapse all

PXE Client Ignoring DHCP Options - ArubaOS-CX

This thread has been viewed 24 times
  • 1.  PXE Client Ignoring DHCP Options - ArubaOS-CX

    Posted 7 days ago
    Hi,

    I am in the process of migrating our DHCP server role from a dedicated DHCP server to our 8325 Core Switch running ArubaOS-CX 10.4.3070. The DHCP scope has been tested and working as expected. However, for imaging PCs we have options 66 and 67 set up to direct to our MDT server (hosted on a different IP range).

    When testing PXE booting from a client, I can see it picks up a DHCP address in the scope, but the "Server IP" it picks up is the IP of the core switch, ignoring the IP in option 66 (Boot Server Host Name).

    The DHCP range being published has routing to the Boot Server and can successfully connection to it. I just can't work out why it is ignoring the DHCP option?!

    The DHCP config is as below:

    dhcp-server vrf default
    pool Data
    range 10.XX.XX.51 10.XX.XX.251
    domain-name XXXX.XXX
    option 67 ascii "98 111 111 116 92 120 54 52 92 119 100 115 109 103 102 119 46 101 102 105"
    default-router 10.XX.XX.254
    dns-server 10.XX.XX.253
    option 66 ip 172.XX.XX.201
    lease 00:08:00
    exit
    authoritative
    enable

    Have I made a glaringly obvious mistake somewhere and just blinkered myself and can't see it? Is there any more info I can provide to help with any suggestions?

    Any help would be very much appreciated!

    Thanks

    ------------------------------
    Ricahrd Matthews
    ------------------------------


  • 2.  RE: PXE Client Ignoring DHCP Options - ArubaOS-CX

    Posted 7 days ago
    you also need option 150 which should point to the PXE server IP address.
    This is what has worked for me.

    dhcp-server vrf Lab

    pool PXE-devs

      range 10.10.11.20 10.10.11.50

      lease 2:00:00

      domain-name lab.arubanetworks.com

      default-router ip 10.10.11.1

      dns-server 1.1.1.1

      netbios-name-server ip x.x.x.x

      option 60 ascii "PXEClient"

      option 66 ascii "name of PXE Server"

      option 150 <ip of PXE Server>

      exit

    enable



    ------------------------------
    Any opinions expressed here are solely my own and not necessarily that of Hewlett Packard Enterprise or Aruba.
    ------------------------------



  • 3.  RE: PXE Client Ignoring DHCP Options - ArubaOS-CX

    Posted 6 days ago

    Hi,

    Thank you for your suggestion - however it seems to have changed the error by using the "option 60 ascii "PXEClient"".

    When we add that option, regardless of the other option we use, we now receive an error stating "No Valid Offer Received". It also no longer shows the "Server IP" on the client when the PXE error appears.

    Previous we would get a "Server IP" showing one of our specific core switches (which is running DHCP) and a complaint that the boot file was not found - which is correct as the boot file sits on our imaging server.

    As a test, I have set up a DHCP server and set the core to run dhcp-relay. the DHCP server (Windows) has been set up with options 66 and 67 and the client now boots to the MDT server, so it feels like there is an issue with the config when running dhcp-server from the Aruba core.

    Is there any way to enable more detailed debugging or logs on the core to see what it is doing? My next option would be to set up wireshark but was hoping I could look at something on the switches first.

    Thanks






    ------------------------------
    Ricahrd Matthews
    ------------------------------



  • 4.  RE: PXE Client Ignoring DHCP Options - ArubaOS-CX

    Posted 6 days ago
    it all depends on how a specific PXE device work.
    so how did this work before? did you run a MS DHCP server?


    ------------------------------
    Any opinions expressed here are solely my own and not necessarily that of Hewlett Packard Enterprise or Aruba.
    ------------------------------



  • 5.  RE: PXE Client Ignoring DHCP Options - ArubaOS-CX

    Posted 6 days ago
    also note that if your PXE devices are on a specific subnet/VLAN, then perhaps the easiest way is not to use DHCP options but instead to configure "IP helper" that would point to the WDS server.

    ------------------------------
    Any opinions expressed here are solely my own and not necessarily that of Hewlett Packard Enterprise or Aruba.
    ------------------------------



  • 6.  RE: PXE Client Ignoring DHCP Options - ArubaOS-CX

    Posted 5 days ago
    I have seen comments about using ip helper instead, but I am struggling to understand this - I have only ever used "ip helper" when dhcp is running on a separate device, along with setting dhcp-relay instead of the dhcp-server option on the switch.

    If I was to keep dhcp running on the core, would I still be able to make use of the ip helper command?

    Thanks

    ------------------------------
    Ricahrd Matthews
    ------------------------------



  • 7.  RE: PXE Client Ignoring DHCP Options - ArubaOS-CX

    Posted 6 days ago
    Our current campus network was Brocade and we had DHCP running on a Windows Server. As part of this work, an onsite datacentre is being moved to an external DC and the Brocade network is being replaced with Aruba. We wanted to run DHCP locally on the cores to allow the site to still semi-function should the connection to the external DC go down.

    So this is basically a new set up of sorts. 

    The thing I found the strangest was that when using the Aruba as the DHCP server, even with option 66 and/or 150, the client device always stated the server IP was the IP of the core switch. We have 2 core switches running VSX, the default gateway set is .254 but the server IP is always .1 - I am just confused why it always uses the server IP as the primary core and not what is set in the options.

    Is there any other config I can show you on the switch that might help?

    Thanks again for your responses on these - it is much appreciated!

    ------------------------------
    Ricahrd Matthews
    ------------------------------



  • 8.  RE: PXE Client Ignoring DHCP Options - ArubaOS-CX

    Posted 5 days ago
    you should be able to use ip helper command that would point to wds server.
    but before that try this. remove the option 60 and i have converted your option 67 to ascii

    dhcp-server vrf Lab
    pool PXE-devs
    range 10.10.11.20 10.10.11.50
    lease 2:00:00
    domain-name lab.arubanetworks.com
    default-router ip 10.10.11.1
    dns-server 1.1.1.1
    netbios-name-server ip x.x.x.x
    option 66 ip <ip-addr of PXE Server>
    option 67 ascii "boot\x64\wdsmgfw.efi"
    option 150  ip <ip-addr of PXE Server>
    exit
    enable

    ------------------------------
    Any opinions expressed here are solely my own and not necessarily that of Hewlett Packard Enterprise or Aruba.
    ------------------------------