Wired Intelligent Edge

 View Only
last person joined: 3 days ago 

Bring performance and reliability to your network with the HPE Aruba Networking Core, Aggregation, and Access layer switches. Discuss the latest features and functionality of your switching devices, and find ways to improve security across your network to bring together a mobile-first solution
Expand all | Collapse all

3500yl (J8692A) Cannot setup routing between VLANs

This thread has been viewed 0 times
  • 1.  3500yl (J8692A) Cannot setup routing between VLANs

    Posted Aug 23, 2013 05:07 AM

    Dear Community,

     

    I am using HP ProCurve 3500yl (J8692A) for my research and now I am trying to build a topology for my experiments. I stuck on configuration of routing between separate VLANs on the same switch. I have built a minimal example to show  my problem and ask you for help.

     

    The question is: How to configure the network so that the address 192.168.2.2 can ping 192.168.6.2 ?

     

    Topology picture: http://img801.imageshack.us/img801/1830/ntw.gif

     

    I think, I have tried everything.

     

    The current status of pings is the following:

    192.168.2.2 (relate2) --> 192.168.2.1 (sw2 VLAN2) OK

    192.168.6.2 (relate6) --> 192.168.6.1 (sw2 VLAN6) OK

    192.168.2.2 (relate2) --> 192.168.6.1 (sw2 VLAN6) NO!

    192.168.6.2 (relate6) --> 192.168.2.1 (sw2 VLAN2) NO!

    Switch can ping every address (2.1, 2.2, 6.1, 6.2)

     

    Configurations:

     

    sw2(config)# sh run
    
    Running configuration:
    
    ; J8692A Configuration Editor; Created on release #K.15.06.0017
    ; Ver #02:10.0d:1f
    
    hostname "sw2" 
    module 1 type J86xxA 
    interface 2 
       name "r2" 
    exit
    ip routing 
    vlan 1 
       name "primary" 
       untagged 1,3-5,7-24 
       ip address 10.0.2.102 255.255.255.0 
       no untagged 2,6 
       exit 
    vlan 2 
       name "to-relate2" 
       untagged 2 
       ip address 192.168.2.1 255.255.255.0 
       exit 
    vlan 6 
       name "to-relate6" 
       untagged 6 
       ip address 192.168.6.1 255.255.255.0 
       exit 
    no ip icmp unreachable 
    ip route 192.168.2.0 255.255.255.0 vlan 2
    ip route 192.168.6.0 255.255.255.0 vlan 6
    snmp-server community "public" unrestricted
    management-vlan 2
    no autorun
    no dhcp config-file-update
    no dhcp image-file-update
    password manager
    password operator

     

    sw2(config)# sh ip route
    
                                                                          IP Route Entries
    
      Destination        Gateway         VLAN Type      Sub-Type   Metric     Dist.
      ------------------ --------------- ---- --------- ---------- ---------- -----
      10.0.2.0/24        primary         1    connected            1          0    
      127.0.0.0/8        reject               static               0          0    
      127.0.0.1/32       lo0                  connected            1          0    
      192.168.2.0/24     to-relate2      2    connected            1          0    
      192.168.6.0/24     to-relate6      6    connected            1          0   
    
    

     

    relate-2:~$ ifconfig eth1
    eth1      Link encap:Ethernet  HWaddr 00:0a:f7:0f:49:0e  
              inet addr:192.168.2.2  Bcast:192.168.2.255  Mask:255.255.255.0
              inet6 addr: fe80::20a:f7ff:fe0f:490e/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:11164 errors:0 dropped:15920 overruns:0 frame:0
              TX packets:24640 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:2376694 (2.3 MB)  TX bytes:24867452 (24.8 MB)
              Interrupt:17 Memory:c6000000-c6012800

     

    relate-2:~$ route
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    default         192.168.2.1     0.0.0.0         UG    0      0        0 eth1
    default         i43-gw-int.ipd. 0.0.0.0         UG    100    0        0 eth2
    141.3.52.0      *               255.255.255.0   U     0      0        0 eth2
    192.168.2.0     *               255.255.255.0   U     0      0        0 eth1

     

    relate-6:~$ ifconfig eth1
    eth1      Link encap:Ethernet  HWaddr 00:0a:f7:0f:49:2a  
              inet addr:192.168.6.2  Bcast:192.168.6.255  Mask:255.255.255.0
              inet6 addr: fe80::20a:f7ff:fe0f:492a/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:77 errors:0 dropped:15920 overruns:0 frame:0
              TX packets:1835 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:5916 (5.9 KB)  TX bytes:202949 (202.9 KB)
              Interrupt:17 Memory:c6000000-c6012800

     

    relate-6:~$ route
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    141.3.52.0      *               255.255.255.0   U     0      0        0 eth3
    192.168.2.0     192.168.6.1     255.255.255.0   UG    0      0        0 eth1
    192.168.6.0     *               255.255.255.0   U     0      0        0 eth1

     


    #3500yl
    #routing
    #vlans


  • 2.  RE: 3500yl (J8692A) Cannot setup routing between VLANs

    Posted Aug 23, 2013 07:54 AM

    HI
    The above configuration looks fine  but we can check few things:
    1) Why do you need static route between VLAN's?
    "IP ROUTING" command should enable inter-vlan routing automatically)Although the switch will use the connected route because he had better metric but still please try to remove it and look if it works).

     

    I can see 2 interfaces on your pc's, their are both linux? Can you please tell me which version?
    From a briefing view the switch looks fine and i suspect that the problem is on your clients.

     

     

     

     



  • 3.  RE: 3500yl (J8692A) Cannot setup routing between VLANs

    Posted Aug 23, 2013 08:04 AM

    Hi,
    thanks for your reply. I also though, that just typing in the "ip routing" would work. I added the other routes just to try some other possibilities – I am struggling with this for two days already.

    My hosts are both Ubuntu server 12.10 and I had no problems with them until now. Physically these are Dells R210II, each with 4x1Gb NICs. If I connect them using a single VLAN pings are working. Which other information from the hosts do you require to point some solution possibilities?

    I wonder if the version of software can play a role here (basic vs. premium). I saw that basic should also support routing. By the way I updated the firmware to K.15.10.0016 but the situation remains the same.



  • 4.  RE: 3500yl (J8692A) Cannot setup routing between VLANs

    Posted Aug 23, 2013 08:30 AM
    No it's not related to the software version or license, i have 12 procurve Layer-3 switches and the above configuration should be enough, IP ROUTING does enable inter-vlan routing for sure so you can remove the static route.

    Have you tried to add default route to the second linux machine? "relate-6".
    I can see default route on the first machine and more specific route on PC 6, please try to add default:
    route add default gw 192.168.6.1.
    I had problem with Red-hat machine with few interfaces, please try to remove any other interface except 192.168.x.x.


  • 5.  RE: 3500yl (J8692A) Cannot setup routing between VLANs

    Posted Aug 23, 2013 08:41 AM
    I was sending all the commands remotely, but now I will go to the datacenter and disconnect everything except the two cables needed for the topology. The same I will do with unused interfaces. I post an update when I am ready.


  • 6.  RE: 3500yl (J8692A) Cannot setup routing between VLANs

    Posted Aug 23, 2013 08:44 AM

    Sorry dude, i have just seen the "management-VLAN" option, it will isolate VLAN-2, please remove that option and try again beside with the tests on the hosts.



  • 7.  RE: 3500yl (J8692A) Cannot setup routing between VLANs

    Posted Aug 23, 2013 10:10 AM

    You are right. Thank you!
    The Management VLAN was the cause of these problems, when I changed it to vlan 1 it started working.

     

    Static routes on the hosts are ok, deafult gateway must also be like it is, because it give the two hosts (out of many) the access to the external network.

     

    Now I come back to my original topology. By keeping trying with this one I learnt a lot, so I will configure the new one much faster :)



  • 8.  RE: 3500yl (J8692A) Cannot setup routing between VLANs

    Posted Aug 23, 2013 11:38 AM

    No other networks in your draw so i didn't knew that you need more routes :) 
     
    Nice experience for you, keep going!