Comware

 View Only
last person joined: yesterday 

Expand all | Collapse all

A5800 and VLAN Configuration

This thread has been viewed 0 times
  • 1.  A5800 and VLAN Configuration

    Posted Jan 31, 2012 11:27 AM

    Hey everyone! I am new to HP networking. I come from a primarily Cisco background and I am attempting to setup my business's server core. I am in the early phases of acclaimating myself with the HP 5800. I have some pretty simple milestones I've set for myself to get familiar with the 5800 and its command system.

     

    I am currently working with an HP A5800-48G. I would like to set ports 1 through 5 to an ipv4 configured vlan 10. VLAN 10 will have the subnet 10.0.10.0/24 (mask 255.255.255.0). The switch itself will be part of  this VLAN as well with a management ip address of 10.0.10.1 (ideally I would like to setup SSH as well). Eventually I would like to configure these ports in a trunk configuration to hook up to some ESXi servers that will use the VLANs maintained by the HP 5800, but I figure baby stes first when getting used to new hardware. So far here's what I have:

     

    vlan 10

    description Test Mgmt VLAN

    protocol-vlan 0 ipv4

    ip-subnet-vlan 0 ip 10.0.10.0 255.255.255.0

    #

    interface vlan-inteface10

    ip address 10.0.10.1 255.255.255.0

    #

    interface GigabitEthernet1/0/1

    port link-mode bridge

    port link-type hybrid

    port hybrid vlan 10 tagged

    port hybrid vlan 1 untagged

    #

    interface GigabitEthernet1/0/2

    ...

    #

    interface GigabitEthernet1/0/3

    ...

    #

    interface GigabitEthernet1/0/4

    ...

    #

    interface GigabitEthernet1/0/5

    ...

     

    I am sure its pretty obvious to someone else what's going on, but when I plugge a laptop into GigabitEthernet1/0/1 of course I cannot ping 10.0.10.1 although it does say the port is up.

     

    Again, I am natively a Cisco guy primarily dealing with 2960gs so any tips or help that can be provided would be awesome. Thanks in advance!


    #VLAN
    #switch
    #Protocol
    #A5800


  • 2.  RE: A5800 and VLAN Configuration

    Posted Jan 31, 2012 03:41 PM

    Just wanted to touch base with this issue. I figured out what I was doing wrong. I finally was able to get into the WebUI purely by fumbling around in the console CLI. Once I got into the WebUI i was able to play around with the permitable options. I have attached the settings I believe I need to configure an access port on interface gi1/0/1 and a trunk port with specific vlans setup on gi 1/0/2 (again, this is just for anyone that cares).

     

    vlan 6

    description Test VLAN

    protocol-vlan 0 ipv4

    ip-subnet-vlan 0 ip 192.168.6.0 255.255.255.0

    #

    vlan 10

    Description Test VLAN 10

    protocol-vlan 0 ipv4

    ip-subnet-vlan 0 ip 192.168.10.0 255.255.255.0

    #

    vlan 100

    description Test VLAN 100

    protocol-vlan 0 ipv4

    ip-subnet-vlan 0 ip 192.168.100.0 255.255.255.0

    #

    vlan 200

    description Test VLAN 200

    protocol-vlan 0 ipv4

    ip-subnet-vlan 0 ip 192.168.200.0 255.255.255.0

    #

    interface Vlan-interface6

    ip address 192.168.6.1 255.255.255.0

    #

    interface Vlan-interface10

    ip address 192.168.10.1 255.255.255.0

    #

    interface Vlan-interface100

    ip address 192.168.100.1 255.255.255.0

    #

    interface Vlan-interface200

    ip address 192.168.100.1 255.255.255.0

    #

    interface GigabitEthernet1/0/1

    description Access Port Example Configuration

    port link-mode bridge

    port access vlan 10

    #

    interface GigabitEthernet1/0/2

    description Trunk Port Example Configuration

    port link-mode bridge

    port link-type trunk

    port trunk permit vlan 1 6 100 200

     

    So basically what happened, was I somehow was able to stumble through the Fundamentals Guide to turn on the http service. From there I configured the VLAN settings under the "Network" context menu on the left. I configured VLAN and VLAN interfaces. Once I configured that information as needed, I did a "display current" from system-view and saw my output. This makes a bit more sense to me now.

     

    I am having some issues setting up HTTPS and SSH though. If anyone has a better tutorial then the one listed in the Fundamentals Guide, I would appreciate the link.

     

    Thanks and I hope this helps someone!



  • 3.  RE: A5800 and VLAN Configuration

    Posted Feb 02, 2012 03:48 PM

    Your interface GigabitEthernet1/0/1 config is faulty.



  • 4.  RE: A5800 and VLAN Configuration

    Posted Feb 02, 2012 03:53 PM

    Cool, care to elaborate? I am currently connected to the switch through an SSH session through that port.

     

    Edit: Please reference the setup illustrated by Khue. That's actually me under an older account registered with a different company. 



  • 5.  RE: A5800 and VLAN Configuration

    Posted Feb 08, 2012 01:54 PM

    Your config is fine - he must have referred the the original config for which you had the vlan tagged on the hybrid type interface...