Wireless Access

 View Only
last person joined: 17 hours ago 

Access network design for branch, remote, outdoor, and campus locations with HPE Aruba Networking access points and mobility controllers.
Expand all | Collapse all

Airmatch error - couldn't connect to server

This thread has been viewed 8 times
  • 1.  Airmatch error - couldn't connect to server

    Posted Sep 13, 2022 06:24 PM

    I'm trying to view some airmatch info via cli, and I'm getting the following error:

    Error: couldn't connect to server at src/mongo/shell/mongo.js:147

    I get this trying to run: 
    show airmatch optimization
    show airmatch solution ap-name <ap-name>
    ...and other cmds.

    Airmatch should be running, as it appears enabled:

    (conductor) [mynode] # show airmatch profile
    AirMatch profile
    Parameter Value
    --------- -----
    schedule Enabled
    deploy-hour 5 AM
    quality-threshold 8 percent

    Couldn't find anything of note in the conductor logs.

    Any ideas on what I could check? Are there processes I could check? Can the airmatch module crash? Thanks for any ideas or direction.

    (Two clustered 7240XM's managed by a pair of clustered MM-VA's, all running

  • 2.  RE: Airmatch error - couldn't connect to server
    Best Answer

    Posted Sep 14, 2022 03:17 AM
    Looks like the database (MongoDB) is not running. AirMatch uses that to store data. You could check the mongodb:
    (MM01) *[mynode] #show netstat | include 27017
    u_str  LISTEN     0      0      /tmp/mongodb-27017.sock 173728929                 * 0     users:(("mongod",pid=24012,fd=19))
    tcp    LISTEN     0      0                     *:*      users:(("mongod",pid=24012,fd=17))
    tcp    ESTAB      0      0      users:(("python",pid=6707,fd=3))​
    ... then the line with LISTEN and; so third line in this example. Every process can potentially crash, but it's not expected, so it may be good to open a TAC case. This is nothing that an end-user should be aware of, in fact, it's the first time I see that this process is running, never bothered as it just works. You could also just reboot your MCR/MM, and see if the process comes back. You can also restart the mongod process: "(MM01) *[mynode] #process restart mongod"; but if it stopped there is probably a reason that needs to be found to prevent the same happening time after time.

    Herman Robers
    If you have urgent issues, always contact your Aruba partner, distributor, or Aruba TAC Support. Check https://www.arubanetworks.com/support-services/contact-support/ for how to contact Aruba TAC. Any opinions expressed here are solely my own and not necessarily that of Hewlett Packard Enterprise or Aruba Networks.

    In case your problem is solved, please invest the time to post a follow-up with the information on how you solved it. Others can benefit from that.

  • 3.  RE: Airmatch error - couldn't connect to server

    Posted Sep 14, 2022 09:37 AM
    Thanks Herman! I'll check what you suggest and possibly open the TAC case. Agreed, it would be nice to know why it crashed.