Controllerless Networks

 View Only
last person joined: 19 hours ago 

Instant Mode - the controllerless Wi-Fi solution that's easy to set up, is loaded with security and smarts, and won't break your budget
Expand all | Collapse all

Aruba 535 AP not using correct cert for WebUI

This thread has been viewed 25 times
  • 1.  Aruba 535 AP not using correct cert for WebUI

    Posted Apr 28, 2023 10:06 AM

    Hi All,

    I uploaded a new cert for an Aruba 535 and marked it as "WebUI", but when I look at the Certificates, the Aruba default cert is still showing as the "Default Server Cert" and when I log into the WebUI, the cert I uploaded isn't being presented.  I don't see a way in the GUI to change this, it only gives me an option to upload a new cert, and add an entry into the Certificate Usage table.

    Is there a trick to this?

    Thanks,
    Joel



  • 2.  RE: Aruba 535 AP not using correct cert for WebUI

    EMPLOYEE
    Posted Apr 28, 2023 11:35 AM

    You can configure the Web UI certificate under Maintenance -> Certifiates -> Certificate Usage:
    Press the + to configure certificates for the different purposes.



    ------------------------------
    Herman Robers
    ------------------------
    If you have urgent issues, always contact your Aruba partner, distributor, or Aruba TAC Support. Check https://www.arubanetworks.com/support-services/contact-support/ for how to contact Aruba TAC. Any opinions expressed here are solely my own and not necessarily that of Hewlett Packard Enterprise or Aruba Networks.

    In case your problem is solved, please invest the time to post a follow-up with the information on how you solved it. Others can benefit from that.
    ------------------------------



  • 3.  RE: Aruba 535 AP not using correct cert for WebUI

    Posted Apr 28, 2023 11:53 AM

    Hi Robert,

    Thanks for the reply.  That is what I've done, but when I go to the web address, that's not the cert that's being used.

    In the Certificates, I see that the "Current Web UI Server Certificate" is the one I uploaded, but when I go to the site.  I've included images of the WebUI Cert the AP tells me it's using vs what I actually see when I login to the WebUI

    Screencap of current WebUI Cert
    The cert I'm presented when logging into WEBUI



  • 4.  RE: Aruba 535 AP not using correct cert for WebUI

    EMPLOYEE
    Posted Apr 30, 2023 01:30 AM

    see if a reboot will show it correctly.



    ------------------------------
    If my post was useful accept solution and/or give kudos.
    Any opinions expressed here are solely my own and not necessarily that of HPE or Aruba.If my post was useful accept solution and/or give kudos.
    Any opinions expressed here are solely my own and not necessarily that of HPE or Aruba.
    ------------------------------



  • 5.  RE: Aruba 535 AP not using correct cert for WebUI

    Posted May 02, 2023 02:56 PM

    A reboot did not resolve this

    Thanks,

    Joel Doetsch




  • 6.  RE: Aruba 535 AP not using correct cert for WebUI

    Posted May 19, 2023 01:05 PM

    Hi Joel,

    You can try to remove the cert and add and assign again as Herman told you.

    In order to remove the cert, you need use the next command:

    crypto pki-remove cert-type ServerCert certname <name of your cert>

    I hope this helps