View Only
last person joined: 2 hours ago 

Forum to discuss Enterprise security using HPE Aruba Networking NAC solutions (ClearPass), Introspect, VIA, 360 Security Exchange, Extensions, and Policy Enforcement Firewall (PEF).
Expand all | Collapse all

ClearPass 6.10 on MS Azure - Cannot morph vm as disk is unavailable

This thread has been viewed 21 times
  • 1.  ClearPass 6.10 on MS Azure - Cannot morph vm as disk is unavailable

    Posted Jul 28, 2022 02:15 AM
    Hi Airheads,

    We are deploying CPPM into our Azure subscription to work alongside an Aruba VPNC deployed there and are unable to run the morph-vm command successfully. We are using the current Azure Marketplace image of CPPM 6.10, which is the intial version (6.10.0). We wanted to apply the latest Cumulative Patch, but due to the relatively small size of the disk with CPPM (40GB), when we first attempted the update, it failed because it ran out of disk space to do the update.

    I have followed the Azure Deployment Guide (ClearPass 6.10 Installation Guide) to the letter, installed all our licenses, completed the bootstrap activity via CLI and can confirm CPPM is working as a RADIUS target for my VPNC.

    When I login to the CLI to perform the system morph-vm C1000V command, it complains that the disk is not available:

    My Azure VM's disks are as follows:

    I am at a loss as I am using an Aruba MarketPlace image and have followed the guides... I have rebuilt this VM 4 times now with minor changes to the underlying VM in an attempt to troubleshoot the issue, with no luck.

    Anyone else have any suggestions?


  • 2.  RE: ClearPass 6.10 on MS Azure - Cannot morph vm as disk is unavailable

    Posted Jul 28, 2022 03:42 AM
    I would expect 3 disks for the morph-vm: OS disk (SCSI0:0; 40GB), the disk for the eval (SCSI0:1; 160GB) and then a new disk of 1000GB (SCSI0:2).

    Can you add a 3rd disk of 1000G and try the morph again? If it works then, you should be able to remove the second disk after the morph and checking that the disk is not used.

    If this is for a production deployment, please work with Aruba Support.

    Herman Robers
    If you have urgent issues, always contact your Aruba partner, distributor, or Aruba TAC Support. Check for how to contact Aruba TAC. Any opinions expressed here are solely my own and not necessarily that of Hewlett Packard Enterprise or Aruba Networks.

    In case your problem is solved, please invest the time to post a follow-up with the information on how you solved it. Others can benefit from that.

  • 3.  RE: ClearPass 6.10 on MS Azure - Cannot morph vm as disk is unavailable

    Posted Sep 01, 2022 01:10 AM
    Hi Herman I took your advice and contacted Aruba Support and they confirmed the Azure CPPM Image only needs 2 disks.

    I was able to work out that the issue was a typo on my end. We use Terraform for our Infrastructure configuration in Azure, and I had specified the wrong type of VM Size. I originally configured a Standard_D2s_v5 Azure VM, which is (currently) the latest generation of VMs offered by Azure.

    The Aruba documentation states it only supports the following VM Sizes:

    I recreated a 'v3' VM and we can now run the morph-vm command without issue.

    Hopefully someone else finds this useful, in case they deploy a later generation of VM and wonder why it's not working.