Security

 View Only
last person joined: 4 hours ago 

Forum to discuss Enterprise security using HPE Aruba Networking NAC solutions (ClearPass), Introspect, VIA, 360 Security Exchange, Extensions, and Policy Enforcement Firewall (PEF).
Expand all | Collapse all

Clearpass - Failing to start Extensions

This thread has been viewed 13 times
  • 1.  Clearpass - Failing to start Extensions

    Posted Jan 24, 2024 10:43 AM

    Hi all

    I am currently running Clearpass in a lab environment with a 180 day evaluation license.

    I have successfully registered my HPE Passport account and licensed the server with the relevant CPPM and onboard licenses. I'm trying to install the Microsoft Intune extension. When installing, it successfully installs, but does not give the extension an IP address. I would expect something in the 172.17.0.1/16 subnet, but it's just blank.

    I've checked that the extension service is running, and the extensions network address is set. This still give the extensions no IP address. Even manually specifying this address does not work. 

    Is there something I've missed, or anything else I can check for running extensions? I don't believe this is a limitation of the trial license, as a coworker had a trial license server previously, and we had multiple extensions running on it.



  • 2.  RE: Clearpass - Failing to start Extensions
    Best Answer

    EMPLOYEE
    Posted Feb 12, 2024 08:23 AM

    Do you have Access Licenses installed and active?

    Does the extension allow you to view it's logs?

    Is your ClearPass server running with the required CPU/MEM/Disk?

    Event log may show something about why the extension is not starting properly.



    ------------------------------
    Herman Robers
    ------------------------
    If you have urgent issues, always contact your Aruba partner, distributor, or Aruba TAC Support. Check https://www.arubanetworks.com/support-services/contact-support/ for how to contact Aruba TAC. Any opinions expressed here are solely my own and not necessarily that of Hewlett Packard Enterprise or Aruba Networks.

    In case your problem is solved, please invest the time to post a follow-up with the information on how you solved it. Others can benefit from that.
    ------------------------------



  • 3.  RE: Clearpass - Failing to start Extensions

    Posted Feb 12, 2024 03:20 PM

    Hi Herman,

    Thanks for responding. I can confirm that I have the following licences loaded:
    Onboard x100
    OnGuard x100
    Access x100
    ClearPass Platform

    The only logs shown by the extensions are "No logs to display"

    The ClearPass VM is running in Hyper-V with the following resources:
    8 cores
    8192MB memory
    1x 45GB Disk & 1x 1TB Disk
    2x NICs

    However, after going through this, I went to double check the license activation, and I've noticed that I never activated the licenses after loading them in. I had activated the platform license, but not the application licenses.

    After activating, the extension has started. It was so simple..

    Thanks for the help, I think this is resolved.