AOS-CX Switch Simulator

 View Only
last person joined: 3 days ago 

Expand all | Collapse all

Error in AOS-CX Simulator Lab - BFD (SW2 Baseline Config)

This thread has been viewed 15 times
  • 1.  Error in AOS-CX Simulator Lab - BFD (SW2 Baseline Config)

    Posted Jul 10, 2023 12:36 PM

    I found an error when running the BFD Simulator Lab. The initial setup configuration for SW2 defines the VLAN 1105 ip address as 192.168.4.11/29. However the BGP configuration for SW1 is referencing 192.168.4.12 as the address configured for communication with SW2. This causes incorrect BGP verification results to be returned and will cause confusion to learns unfamiliar with troubleshooting the protocol.

    The correct setup config is below:

    hostname SW2
    !
    vlan 1
    vlan 1105
     description transit interco VLAN
    interface mgmt
     no shutdown
     ip dhcp

    interface 1/1/1
     no shutdown
     description to SW3
     no routing
     vlan access 1105
    interface 1/1/9
     no shutdown
     description to SW1
     no routing
     vlan access 1105
    interface vlan 1105
     ip address 192.168.4.12/29



  • 2.  RE: Error in AOS-CX Simulator Lab - BFD (SW2 Baseline Config)

    Posted Jul 11, 2023 03:52 AM

    Hi, are you sure? The sw2 is just a transit switch and not supposed to be part of BGP peering. The 192.168.4.11 address is just for verification of the path between sw1 and sw3 over sw2.



    ------------------------------
    Arne Opdal
    ------------------------------



  • 3.  RE: Error in AOS-CX Simulator Lab - BFD (SW2 Baseline Config)

    Posted Jul 11, 2023 10:49 AM

    ArneO,

    Thanks for your input, turns out I discovered later in the evening that I was wrong (yes, I'm admitting it).

    Configuring the lab as stated in the lab guide the results in my verification steps were grossly inconsistent with what was contained in the text. After troubleshooting I found that 192.168.2.1 would not peer with 192.168.2.2 and gave a "bgp connection rejected error", nor could I ping 192.168.2.1 with the host. Pinging .112 failed everywhere (including SW3), but .111 worked. I then missed the fact that .112 was actually assigned to VLAN 1105 on SW3 and made a rookie mistake assuming it was a typo in the SW2 config. I changed the IP on VLAN 1105 to .112 and things started working (I thought). The "connection rejected" error went away, the outputs matched the lab guide, and the pings worked - for a while. After a minute or so the HostA pings began alternating between succeeding a failing every 30 seconds or so. After spinning my wheels for a while, I decide to shut down the simulators and reload the labs. This returned SW2  to the "before I fixed it state", i.e. configured per the lab guide, and everything worked as advertised.

    Seems the issues I saw were related to some sort of issue within the simulator environment.

    Oops...

    I should actually delete this string but couldn't figure out how, or even if possible.

    Batting a thousand here...