Wired Intelligent Edge

 View Only
last person joined: 2 days ago 

Bring performance and reliability to your network with the Aruba Core, Aggregation, and Access layer switches. Discuss the latest features and functionality of the ArubaOS-Switch and ArubaOS-CX devices, and find ways to improve security across your network to bring together a mobile first solution.
Expand all | Collapse all

Error while installing line card into 6400 switch

This thread has been viewed 15 times
  • 1.  Error while installing line card into 6400 switch

    Posted 25 days ago
    Hi,

    I have problem installing Line Card into 6400 switch. I have double 6400 working in VSX cluster. After inserting line card to one member the line card is initializing, updating and then deinitializing due to VSX config error. Hrere is some logs:

    2022-11-09T13:26:07.689584+01:00 SWITCH hpe-cardd[1363]: Event|3202|LOG_WARN|AMM|1/1|Line module 1/5 removed

    2022-11-09T13:25:43.000829+01:00 SWITCH ops_mgmtintfcfg[6183]: Event|4301|LOG_INFO|AMM|-|MGMT_INTF: Configured admin status up on Mgmt interface

    2022-11-09T13:25:42.959188+01:00 SWITCH hpe-cardd[1363]: Event|3207|LOG_ERR|AMM|1/1|Line module 1/5 has failed: Internal error during VSX configuration

    2022-11-09T13:25:23.118948+01:00 SWITCH systemd-coredump[1609]: Event|1201|LOG_CRIT|LC|1/5|_switchd_agent2 crashed due to signal:6

    2022-11-09T13:23:34.414496+01:00 SWITCH hpe-sysmond[1609]: Event|6303|LOG_INFO|LC|1/5|Current system memory usage for module 1/5 is 26%

    2022-11-09T13:23:06.540372+01:00 SWITCH hpe-cardd[1363]: Event|3221|LOG_DEBUG|AMM|1/1|Line module 1/5 device initialization started

    2022-11-09T13:23:06.540181+01:00 SWITCH hpe-cardd[1363]: Event|3219|LOG_DEBUG|AMM|1/1|Line module 1/5 main power enabled

    2022-11-09T13:23:04.448612+01:00 SWITCH hpe-cardd[1363]: Event|3218|LOG_DEBUG|AMM|1/1|Line module 1/5 enabling main power

    2022-11-09T13:23:04.437038+01:00 SWITCH hpe-cardd[1363]: Event|3211|LOG_INFO|AMM|1/1|Line module 1/5 ISP passed

    2022-11-09T13:22:58.463564+01:00 SWITCH hpe-cardd[1363]: Event|3237|LOG_INFO|AMM|1/1|Line module 1/5 initiating ISP

    2022-11-09T13:22:57.444095+01:00 SWITCH hpe-cardd[1363]: Event|3214|LOG_DEBUG|AMM|1/1|Line module 1/5 has enabled standby power

    2022-11-09T13:22:53.522612+01:00 SWITCH dpsed[1588]: Event|10903|LOG_INFO|AMM|1/1|HA event completed backplane sequence recovery

    2022-11-09T13:22:52.794130+01:00 SWITCH dpsed[1588]: Event|10902|LOG_INFO|AMM|1/1|HA event triggered backplane sequence recovery

    2022-11-09T13:22:47.379223+01:00 SWITCH hpe-cardd[1363]: Event|3203|LOG_INFO|AMM|1/1|Initiating Line module 1/5 reboot
    What can be the cause of this problem? After error switch tries to initialize card again and again.


  • 2.  RE: Error while installing line card into 6400 switch

    EMPLOYEE
    Posted 24 days ago
    Hi,

    Seems like a software or compatibility issue. What is the AOS-CX software version your 6400 running and what is the line card's model/part number?

    ------------------------------
    Ivan Bondar
    ------------------------------



  • 3.  RE: Error while installing line card into 6400 switch

    Posted 24 days ago
    Version : FL.10.07.0020
    Line card: R0X44A

    The same config of line cards is working properly in first node of VSX


  • 4.  RE: Error while installing line card into 6400 switch

    EMPLOYEE
    Posted 24 days ago
    The fact the issue doesn't appear in another VSX peer running the same software doesn't mean it can't be a software issue. Even more, I clearly see indications that it is software issue:

    systemd-coredump[1609]: Event|1201|LOG_CRIT|LC|1/5|_switchd_agent2 crashed due to signal:6

    Crash with signal 6 is seen when a process is terminated with SIGABRT signal due to critical uncorrectable error.

    Of course it may be provoked by a hardware issue, but chances this is a software glitch are much higher. BTW, VSX is not a stack, so configuration-wise both peers are not identical, they may have different configuration (like standalone ports), different states (like IP routing, dynamic peering etc) so again, the fact the LC works in one peer and doesn't in another is not enough to conclude it's not a s/w bug.

    10.07 is not supported from 15-Apr-2022 (you can check end of support dates here - https://www.arubanetworks.com/support-services/end-of-life/ ) I suggest you to upgrade to 10.09.1xxx or better to the 10.10.1xxx which is LSR (long supported release). More information about release types and difference between them you can find here - https://www.arubanetworks.com/support-services/end-of-life/arubaos-software-release/

    Maybe it's a good idea to contact Aruba TAC for deeper investigation, but be prepared for request to upgrade 🙂

    ------------------------------
    Ivan Bondar
    ------------------------------