There is an HP 1920 switch with 24 ports, and it needs to be divided into two separate virtual switches. For example, port 1-8 is vlan 1, and port 9-24 is vlan 21. Both Vlans must use the same subnet, for example 10.0.0.1/24. Gateway 10.0.0.1 is plugged into port 1, computer 10.0.0.21 is plugged into port 21. Access of computer 10.0.0.21 to gateway 10.0.0.1 should appear only if both vlan-based virtual switches are connected via port 8 - 9.
#
vlan 1
#
vlan 21
description VLAN 0021 test
#
interface GigabitEthernet1/0/1 - 7
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/8
port link-type hybrid
port hybrid vlan 1 21 tagged
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/9
port link-type hybrid
port hybrid vlan 1 21 tagged
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/10 - 24
port access vlan 21
port auto-power-down
stp edged-port enable
#