Comware

 View Only
last person joined: 2 days ago 

Expand all | Collapse all

HP 5820 (JG219A) - Sub- Interface

This thread has been viewed 1 times
  • 1.  HP 5820 (JG219A) - Sub- Interface

    Posted Feb 17, 2015 09:00 AM

    Hi,

     

    can anyone help?

     

    I need to create a sub interface on HP 5820. However, it seems it´s not possible to create this interface:

     

    HP Comware Platform Software
    Comware Software, Version 5.20.105, Release 1808P12
    HP A5820AF-24XG Switch with 2 Processors
    1024M   bytes SDRAM
    4M      bytes Nor Flash Memory
    512M    bytes Nand Flash Memory
    Config Register points to Nand Flash

    Hardware Version is Ver.B
    CPLDA Version is 002, CPLDB Version is 005
    BootRom Version is 220
    [SubSlot 0] 24SFP Plus+2GE Hardware Version is Ver.B

     

    Desired Config:

    ip vpn-instance app-vprn110

    route-distinguisher 192.168.0.1:1158

    description 'VRF Up_HP_App_1'

    #

    ip vpn-instance oam-vprn10

    route-distinguisher 192.168.0.25:1160

    description 'VRF Up_HP_OAM_1'

    #

    interface GigabitEthernet0/0/2

    port link-mode route

    combo enable copper

    #

    interface GigabitEthernet0/0/2.1158

    ip binding vpn-instance app-vprn110

    ip address 192.168.0.2 255.255.255.252

    #

    interface GigabitEthernet0/0/2.1160

    ip binding vpn-instance oam-vprn10

    ip address 192.168.0.26 255.255.255.252

    #

    ip route-static vpn-instance app-vprn110 0.0.0.0 0 192.168.0.1

    ip route-static vpn-instance oam-vprn10 0.0.0.0 0 192.168.0.25

    #

     

    Thanks,

    Michael



  • 2.  RE: HP 5820 (JG219A) - Sub- Interface

    Posted Feb 17, 2015 12:09 PM

    As a start I would update to the 1809P02 firmware just to rule out any fixes in between the latest version (1809P02) and the one you currently run (1808P12):

     

    https://h10145.www1.hp.com/Downloads/SoftwareReleases.aspx?ProductNumber=JG219A

     

    Regarding sub-interface you mean to have two different (tagged) vlans on the same physical interface or that you need an additional ip set for a particular VLAN and what is the purpose in that case?

     

    On the 5820 (JC102A) you define a sub-interface like:

     

    >ip address x.x.x.x y.y.y.y sub

     



  • 3.  RE: HP 5820 (JG219A) - Sub- Interface

    Posted Feb 18, 2015 04:58 AM

    As far as I understand on routing level vlans are not really required or used.

     

    However, what we have to do here is:

    We have several subnets with tagged VLANs, e.g. APP = Application & OAM = Operation and Maintenance

    APP has 1158 and OAM has 1160 as tag. Both shall be transported via the same uplink port on level 3.

    The uplink port is considered to be the transport net. Transportnet will have to different ip´s.

    We found a solution using VRF but this is not what we want. Creating sub- interfaces using the "sub" statement doesn´t give the possibility to attach the VLAN- ID of the transport net.

    Maybe it´s not really necessary to have any tags on the transport net?

     

    Regards



  • 4.  RE: HP 5820 (JG219A) - Sub- Interface

    Posted Feb 18, 2015 02:06 PM

    Here is how I would do that on a HP 5820 (JC102A):

     

    #
    vlan 1158
    description APP
    #
    vlan 1160
    description OAM
    #
    vlan 1234
    description UPLINK
    #
    interface Vlan-interface1158
    description APP
    ip address x.x.x.x y.y.y.y
    #
    interface Vlan-interface1160
    description OAM
    ip address x.x.x.x y.y.y.y
    #
    interface Vlan-interface1234
    description UPLINK
    ip address x.x.x.x y.y.y.y
    #
    interface Ten-GigabitEthernet1/0/1
    port link-mode bridge
    description DOWNLINK
    port link-type trunk
    undo port trunk permit vlan 1
    port trunk permit vlan 1158 1160
    port trunk pvid vlan 3101
    undo jumboframe enable
    #
    interface Ten-GigabitEthernet1/0/24
    port link-mode bridge
    description UPLINK
    port link-type trunk
    undo port trunk permit vlan 1
    port trunk permit vlan 1234
    port trunk pvid vlan 3124
    undo jumboframe enable
    #
    ip route-static 0.0.0.0 0.0.0.0 Vlan-interface1234 x.x.x.x permanent


    In the above example VLAN1158 and 1160 is put as tagged on downlink and VLAN1234 is put as tagged on uplink.



  • 5.  RE: HP 5820 (JG219A) - Sub- Interface

    Posted Feb 19, 2015 04:52 AM

    Thanks for the info. Somehow like this is what we did by now.

    However, isn´t trunk or bridge, as well as vlans layer 2?

    We were asked to make the port a routing port...

     

    By the way, the above example is from the HP simulator.



  • 6.  RE: HP 5820 (JG219A) - Sub- Interface

    Posted Feb 19, 2015 05:40 PM

    Well either you use "port link-mode bridge" along with vlans or "port link-mode route" and no vlans.

     

    I prefer the first method, better granularity. The second method is perhaps more foolproof against L2-loops (like with VLAN you can cause a loop if you setup the same VLAN on 2 or more physical interfaces).



  • 7.  RE: HP 5820 (JG219A) - Sub- Interface

    Posted Feb 20, 2016 12:45 PM

    Hi.

    When you use a bridge interface you also utilize spanning tree protocol (STP) if enabled.

    A route interface does not utilize STP.

    Usually in comware you can access the sub interface configuration but specifing it with a dot.

    First you should set the parent (physical) interface in route mode then you can access the sub interface

    #

    interface ten 1/0/2.1186

    ip addess 10.11..12.254 24

    description GW for VLAN 1186.

    #

    Not sure if the exact hardware and firmware combination allows this, but this would be the general way to do this.


    #bridge
    #route
    #comware
    #subinterface


  • 8.  RE: HP 5820 (JG219A) - Sub- Interface

    Posted Jul 03, 2017 07:46 AM

    Dear sir,

     

    here I am attaching my network daigram.

    I have hp-5900 switches and i have created multiple vlan and interfaces like below

    vlan 2   - int-vlan-2-ip -10.1.2.1

    vlan 4- int-vlan-4-ip -10.1.4.1

    vlan 6- int-vlan-6-ip- -10.1.6.1

    I have server vlan -100, int-vlan100-10.1.100.1

    my vlan are communicating to each other but i have to configure a virtual interfaces regardless of all respactive vlan so to communicate to each other for internet.

    I want that if any client accesing my intranet vlan that is server (vlan 100), shouldnt go for router (dell sonic wall ) i mean it shoul route by hp-l3 switch when because of this lots latency is there