View Only
last person joined: 5 days ago 

Expand all | Collapse all

HP v1910 / DHCP Request

This thread has been viewed 0 times
  • 1.  HP v1910 / DHCP Request

    Posted Apr 22, 2015 09:29 AM

    So I have an interesting situation where I have a non-standard device that needs to get on my flat network by using DHCP, but cannot get a DHCP address.  It is PoE and runs Windows CE.  I have 3 different HP v1910 JE007 switches that I have plugged this device into, PoE works, but the device will not get an IP from the DHCP server that's on the same subnet, being it's an entirely flat network.


    With that said, we also have some small 8 port Netgear switches/hubs that have 4 PoE ports that are also uplinked back to either one of the above 3 switches or to another 48 port HP v1910 that's non-PoE, AND it works!!  This device has also been taken offsite to a location I believe using yet another brand of switches and it works fine.  So what in the 1910 switch is not allowing DHCP requests to be processed?  The configurations are all very standard and aren't doing any kind of port security of any kind.  Here's another catch:  other devices such as standard Windows 7 laptops get DHCP fine on all of these switches.


    This device I'm plugging in is an Evoko wall panel that links to our Exchange server in order to show the calendar schedule of a conference room.  It is to be mounted on a wall directly outside of the room.  I've tried doing a port mirror on both the 1910 and the Netgear switch and I never see the MAC come through on the 1910, but I catch it right away on the Netgear.  Can anyone point me in the right direction?  I just upgraded one of the 1910s to one of the latest versions of software and still no luck.  Please help!  Thanks!


  • 2.  RE: HP v1910 / DHCP Request

    Posted Apr 22, 2015 09:39 PM

    Get on the switch and find out the status of the port the Evoko is patched to.

    Is it up?

    What is its PoE status?

    What speed has it negotiated?
    What is spanning tree doing?

    WHat are the switchport traffic and error statistics?


    Check the switch log (change it to log info/debug first), and observe the switch logging events when you patch in the Evoko.

    What is it doing when you patch it in?


    In the event that auto-negotiation is failing and/or there are errors on the port, change the switchport to 100/Full duplex instead of Auto, and see if anything change.

    (Remember to set it back to Auto after testing this).

  • 3.  RE: HP v1910 / DHCP Request

    Posted Apr 23, 2015 11:11 AM

    As soon as you mentioned interface statistics, I remembered seeing errors on that port.  I'm new to HP switching and my troubleshooting mind isn't quite there.  So, with that said, I immediately started playing around with interface settings, ultimately finding that it needed to be hard-coded at 100/Full.  It works fine now.  Appreciate the input!  Thanks!