Wireless Access

 View Only
last person joined: 13 hours ago 

Access network design for branch, remote, outdoor and campus locations with Aruba access points, and mobility controllers.
Expand all | Collapse all

IAP-315 not obtaining IP / DHCP Failing

This thread has been viewed 14 times
  • 1.  IAP-315 not obtaining IP / DHCP Failing

    Posted 26 days ago

    Hi everyone, 

    I promised to not give up on this one too quick, so asking for help is kinda my last step here! I've purchased a IAP-315 for very cheap money on ebay a few days ago, was of course (we all know it) very excited to plug it in and get my wifi just awesome. Well, spoiler: It did not go that way.

    I'm running into issues here, the IAP is showing the Power LED, awesome - however, after booting I wouldn't say it's blinking anymore, it switches to a short "flash" rather. I though okay, I'm going to be smart here, resetting it to factory defaults with a pin. Yeah, that didn't help either... the next night.. I cant sleep, looking for ways to debug this thing. Buying a shiny tll thingy to console access it.

    Yeah, that thing just came. Opened the console access, reset it (yet again) to factory defaults, but nothing. When booting the little IAP it does not seem to communicate with the Router (I want to run this thing at home, no Controller/Master). I have connected it to a switch, where I'd see if any traffic was sent through the Switch, but those LEDs are not lighting up at all.

    I ran a few commands... for example this one:

    apboot> dhcp
    eth0: link down
    DHCP broadcast 1

    However, after booting and logging in I also see the following information:

    Warning: CLI module is running in a degraded state.  Configuration, write memory, and support command are disabled; please debug with caution.

    Could that be related to this thingy being (still) set to working as a AP and looking for a master instead of being set to a IAP? I mean I have done multiple factory defaults, but I do not know how to fix this.

    Thanks for assisting guys!


  • 2.  RE: IAP-315 not obtaining IP / DHCP Failing

    Posted 26 days ago

    This AP may still be assigned to a customers Aruba Central Account. Try factory resetting it on a network without access to the internet. If that fixes it, then the customer who currently has this AP in its inventory needs to release it. 

    Dustin Burns

    Lead Mobility Engineer @Worldcom Exchange, Inc.

    ACCX 1271| ACMX 509| ACSP | ACDA | MVP Guru 2022-2023
    If my post was useful accept solution and/or give kudos

  • 3.  RE: IAP-315 not obtaining IP / DHCP Failing

    Posted 24 days ago

    The log shows 'eth0 link down' which suggest the AP is not connected to your switch. If the switch doesn't show link lights, that supports that.

    Are you sure the ethernet cable between AP and switch is correct?

    What type of switch do you have? And how do you power the AP?

    The degraded state also happens if the AP is powered but has no network/IP address.

    Herman Robers
    If you have urgent issues, always contact your Aruba partner, distributor, or Aruba TAC Support. Check https://www.arubanetworks.com/support-services/contact-support/ for how to contact Aruba TAC. Any opinions expressed here are solely my own and not necessarily that of Hewlett Packard Enterprise or Aruba Networks.

    In case your problem is solved, please invest the time to post a follow-up with the information on how you solved it. Others can benefit from that.