Controllerless Networks

 View Only
last person joined: 20 hours ago 

Aruba Instant Wi-Fi: Meet the controllerless Wi-Fi solution that's easy to set-up, is loaded with security and smarts, and won't break your budget.
Expand all | Collapse all

IAP335 APB Beacon not working

This thread has been viewed 7 times
  • 1.  IAP335 APB Beacon not working

    Posted Jun 14, 2022 03:11 PM
    Hi,

    I am setting up an Aruba IAP335 controller. Trying to test the BLE IoT service (using WebSocket). I have set up and used both radio-profile and transportProfile.

    Aruba_ap1# show running-config | include iot

    iot radio-profile test

    iot transportProfile chorus_test

    iot use-radio-profile test

    iot useTransportProfile chorus_test


    I also set up my WebSocket server and can receive some beacon. However, the beacon has no BleData included. It only contains the following data:

    meta {

      version: 1

      access_token: "aabbccddee"

    }

    reporter {

      name: "Aruba_ap1"

      mac: "......"

      ipv4: "192.168.1.93"

      hwType: "AP-335"

      swVersion: "8.8.0.0-8.8.0.0-mm-dev"

      swBuild: "77366"

      time: 1655077928

    }


    Don't know what's going on. One thing I noticed is that the APB seems to be disabled (see the information highlighted below). Even although I chose "Beaconing" option. 

    Radio Configuration

    -------------------

    Item                          Value

    ----                          -----

    Radio Information             TI ONBOARD Internal BLE 

    Radio Profile Type            --

    Zigbee Supported              No

    APB MAC Address               f4:5e:ab:bb:49:87

    Operational Mode              Beaconing (APB: Disabled)

    Operational BluOS FW Version  OAD B 1.2-42

    Bundled BluOS Upgrade         Enabled (-1)

    Bundled BluOS Images          Bank A(/aruba/bin/UpgradeImage_AP_OAD-A_1.2-42.bin) Bank B(/aruba/bin/Beacon_AP_OAD-B_1.2-42.bin)

    OTA FW BluOS Upgrade          Disabled

    FW Stack Supported            No


    Don't know if this is the root cause and how to solve it. Any suggestions? Thtanks!





  • 2.  RE: IAP335 APB Beacon not working

    EMPLOYEE
    Posted Jun 18, 2022 07:21 PM
    what instant version are you running?
    see if this command gives you any ideas about where the issue is.
    show ap deb ble-relay disp-attr all

    ------------------------------
    Any opinions expressed here are solely my own and not necessarily that of Hewlett Packard Enterprise or Aruba.
    ------------------------------



  • 3.  RE: IAP335 APB Beacon not working

    Posted Jun 19, 2022 11:56 AM
    Interestingly, I made no changes in the past few days and only turned off the Aruba AP. After I turned it on, the APB beaconing is working. Last week, I thought about rebooting the device may help before and I did the reboot, but still have the same issue. Looks like I just need to let the device to be quiet for some time, and it can fix the APB itself. That's really strange. 

    Aruba_ap1# show iot radio-profile test        

    Name                :test

    References          :1

    Instance            :internal

    Mode                :ble

    BLE Opmode          :scanning beaconing

    BLE Console         :on

    BLE TxPower (dBm)   :0

    Zigbee Mode         :coordinator

    Zigbee Channel(s)   :auto