Wired Intelligent Edge

 View Only
last person joined: 2 days ago 

Bring performance and reliability to your network with the Aruba Core, Aggregation, and Access layer switches. Discuss the latest features and functionality of the ArubaOS-Switch and ArubaOS-CX devices, and find ways to improve security across your network to bring together a mobile first solution.
Expand all | Collapse all

Ping not working in HPE Aruba 2930F with Openflow aggregate mode enabled

This thread has been viewed 7 times
  • 1.  Ping not working in HPE Aruba 2930F with Openflow aggregate mode enabled

    Posted 20 days ago

    I have an HPE Aruba 2930F JL259A switch which is used to try out SDN related experiments. But after the aggregate mode instance is enabled , the ping command does not work. It results in "Request timeout out" response.

    Aruba-2930F-24G-4SFP(config)# show VLANS

    Status and Counters - VLAN Information

    Maximum VLANs to support : 256
    Primary VLAN : DEFAULT_VLAN
    Management VLAN : DEFAULT_VLAN

    VLAN ID Name | Status Voice Jumbo
    ------- -------------------------------- + ---------- ----- -----
    1 DEFAULT_VLAN | Port-based No No
    2 OF_CONTROLLER_VLAN | Port-based No No
    3 OF_HOST_VLAN | Port-based No No

    1. DEFAULT_VLAN (Primary VLAN) - Ports 1-6, IP Address 192.168.10.3 (Default IP: 192.168.10.1)

    2. OF_CONTROLLER_VLAN - Ports 7-12, IP Address 192.168.11.1 

    3. OF_HOST_VLAN - Ports 13-28, IP Address 192.168.12.1

    Aruba-2930F-24G-4SFP(config)# show openflow instance aggregate

    Configured OF Version : 1.3
    Negotiated OF Version : 1.3
    Instance Name : aggregate
    Data-path Description : aggregate
    Administrator Status : Enabled
    Member List : VLAN 3
    Pipeline Model : Standard Match
    Listen Port : None
    Operational Status : Up
    Operational Status Reason : NA
    Datapath ID : 0003187a3b34dee0
    Mode : Active
    Flow Location : Hardware and Software
    No. of Hardware Flows : 2
    No. of Software Flows : 1
    Hardware Rate Limit : 0 kbps
    Software Rate Limit : 100 pps
    Conn. Interrupt Mode : Fail-Secure
    Maximum Backoff Interval : 60 seconds
    Probe Interval : 10 seconds
    Hardware Table Miss Count : NA
    No. of Software Flow Tables : 1
    Egress Only Ports : None
    Table Model : Policy Engine and Software
    Source MAC Group Table : Disabled
    Destination MAC Group Table : Disabled
    Default Miss Action : Drop
    Packet-In VLAN Tagging : Default

    Controller Id Connection Status Connection State Secure Role
    ------------- ----------------- ---------------- ------ ------
    1 Connected Active No Equal

    I'm using the RYU controller, and the initial handshake connection and configuration from the RYU side with switch seems to working correctly.

    Controller IP Address: 192.168.11.2

     

    Aruba-2930F-24G-4SFP(config)# show run

    Running configuration:

    ; JL259A Configuration Editor; Created on release #WC.16.10.0009
    ; Ver #14:67.6f.f8.1d.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:44
    hostname "Aruba-2930F-24G-4SFP"
    module 1 type jl259a
    ip default-gateway 192.168.10.1
    snmp-server community "public"
    openflow
    controller-id 1 ip 192.168.11.2 controller-interface vlan 2
    instance aggregate
    controller-id 1
    version 1.3
    enable
    exit
    enable
    exit
    vlan 1
    name "DEFAULT_VLAN"
    no untagged 7-28
    untagged 1-6
    ip address 192.168.10.3 255.255.255.0
    ipv6 enable
    ipv6 address autoconfig
    ipv6 address dhcp full
    exit
    vlan 2
    name "OF_CONTROLLER_VLAN"
    untagged 7-12
    ip address 192.168.11.1 255.255.255.0
    ipv6 enable
    ipv6 address autoconfig
    exit
    vlan 3
    name "OF_HOST_VLAN"
    untagged 13-28
    ip address 192.168.12.1 255.255.255.0
    ipv6 enable
    ipv6 address autoconfig
    exit
    management-vlan 1
    no tftp server
    no autorun
    no dhcp config-file-update
    no dhcp image-file-update
    password manager

    Any idea/suggestion as to why this is happening and what can be done would be really helpful, thanks!



  • 2.  RE: Ping not working in HPE Aruba 2930F with Openflow aggregate mode enabled

    EMPLOYEE
    Posted 18 days ago
    Not sure if you can name your instance aggregate. As far as I know, the aggregate keyword is for show commands to check across different instances.

    Maybe this video may help to get proper configuration on your switch. It's with a different SDN controller, but the switch part should be similar.

    Please note that I have not seen Openflow for quite some time. The interest for it seems quite low these days. The feature is great, but has not delivered what everyone hoped from it. With Aruba Dynamic Segmentation/User based Tunnel/Aruba Central Netconductor, you can do similar things in a wider used way.

    ------------------------------
    Herman Robers
    ------------------------
    If you have urgent issues, always contact your Aruba partner, distributor, or Aruba TAC Support. Check https://www.arubanetworks.com/support-services/contact-support/ for how to contact Aruba TAC. Any opinions expressed here are solely my own and not necessarily that of Hewlett Packard Enterprise or Aruba Networks.

    In case your problem is solved, please invest the time to post a follow-up with the information on how you solved it. Others can benefit from that.
    ------------------------------