Wireless Access

 View Only
last person joined: yesterday 

Access network design for branch, remote, outdoor, and campus locations with HPE Aruba Networking access points and mobility controllers.
Expand all | Collapse all

Remotely Factory Default an AP

This thread has been viewed 170 times
  • 1.  Remotely Factory Default an AP

    Posted Mar 07, 2017 03:26 PM

    Is there any way to remotely factory default an access point (in my case an AP225)?  Can it be done from the controller?  Can it be done from a telnet session?


    I have an AP which is not trivial to physically get to that I need to factory default.  It's stuck to some AOS8 controller which I no longer want this specific AP on ... and I am unable to make it move ...


    Any thoughts?

  • 2.  RE: Remotely Factory Default an AP
    Best Answer

    Posted Mar 07, 2017 03:37 PM

    Not that I am aware of.  So you can not reprovision the AP from the controller and put it in a different AP group with a different system profile to a controller you want to move the AP to?

    If not then you have to physically console into the device and purge it.

  • 3.  RE: Remotely Factory Default an AP

    Posted Jul 19, 2017 10:14 PM

    Factory reset a single AP:

    From the Master controller CLI in enable mode:

    1. Go into configuration mode: #configure terminal 
    2. Go into provisioning mode: #provision-ap 
    3. Retrieve current provisioning parameters of the AP to be (re)-provisioned (default for new AP's): #reset-bootinfo {ap-name | ip-addr | wired-mac} <variable>

    Brant Highers

    Solutions Architect

    Profesional Services Enablement


  • 4.  RE: Remotely Factory Default an AP

    Posted Dec 02, 2022 12:39 PM

    Hi Brant,

    uhm, I have a short question, do you know if the option still works today with ARUBA OS8.x?

    The KB of commands still shows the reset-bootinfo command, but so far I'm not able to use the "provision-ap" command in the CLI of the MC.

    Does you or anyone other community member have an idea? :)

    Thank you very much in advance!

    Best regards


  • 5.  RE: Remotely Factory Default an AP

    Posted Dec 05, 2022 04:44 AM
    If you have a MM/MCR, you may need to do the action from there. In my lab (8.10), I can enter the provision-ap command on both MCR as MD:
    (md7005) #provision-ap reprovision
    all                     Reprovision all APs in provisioning_ap_list
    ap-name                 Reprovision AP with this name
    ip-addr                 Reprovision AP at this IP address
    ip6-addr                Reprovision AP at this IPv6 address
    serial-num              Reprovision AP with this serial number
    wired-mac               Reprovision AP at this MAC address
    (md7005) #provision-ap reprovision all
    (md7005) #res
    reset-bootinfo          Restore factory default boot variables
    restore                 restore file or configuration​

    Herman Robers
    If you have urgent issues, always contact your Aruba partner, distributor, or Aruba TAC Support. Check https://www.arubanetworks.com/support-services/contact-support/ for how to contact Aruba TAC. Any opinions expressed here are solely my own and not necessarily that of Hewlett Packard Enterprise or Aruba Networks.

    In case your problem is solved, please invest the time to post a follow-up with the information on how you solved it. Others can benefit from that.

  • 6.  RE: Remotely Factory Default an AP

    Posted May 22, 2023 06:28 AM

    Hoping it OK to keep this thread going:

    We provision APs with whitelist-db. 
    Lately had lots of APs to re-name or re-group (the new group was to move them onto a new cluster via LMS IP). Mostly this went fine using Excel and the following:

    whitelist-db cpsec modify mac-address <MAC> ap-group <New Group>
    Followed by:
    ap-regroup wired-mac <MAC> <New Group>

    But some APs got 'stuck' in some way and required a further
    reset-bootinfo wired-mac <MAC>

    My problem is that some further APs refuse to change group or name. The whitelist-db shows the correct info, but the ap-regroup, ap-rename, and reset-bootinfo commands cause the APs to reboot, but they come back up with old details rather than what the whitelist shows.
    I tried the provision-ap reprovision wired-mac <MAC> commmand but that didn't help either. 
    I think I was flat out of luck at the point reset-bootinfo failed to work. What do I do now?

    e.g. Trying to rename and regroup cluster02-test / SouthW-Std-InRoom to Test-AP / South-Std (attempted in separate steps for name and group)

    show whitelist-db cpsec mac-address 28:de:65:05:1a:73
    Control-Plane Security Allowlist-entry Details
    MAC-Address        AP-Group   AP-Name      Enable   State                   Cert-Type     Description  Revoke Text  Last Updated
    -----------        --------   -------      ------   -----                   ---------     -----------  -----------  ------------
    28:de:65:05:1a:73  South-Std  Test-AP  Enabled  certified-factory-cert  factory-cert                            Mon May 22 10:43:37 2023

    show ap details wired-mac 28:DE:65:05:1A:73
    AP "cluster02-test" Basic Information
    Item                 Value
    ----                 -----
    AP IP Address
    LMS IP Address
    Group                SouthW-Std-InRoom
    Location Name(FQLN)  N/A
    Status               Up
    Up time              4m:24s
    AP "cluster02-test" Hardware Information
    Item                Value
    ----                -----
    AP Type             503H
    Serial #            CNLNKSLBL5
    Wired MAC Address   28:de:65:05:1a:73

    (net-mc07) [MDC] *#show ap active ap-name cluster02-test
    Active AP Table
    Name                Group              IP Address   AP Type  Flags  Uptime   Outer IP  Cluster Role  Radio 0 Band Ch/EIRP/MaxEIRP/Clients  Radio 1 Band Ch/EIRP/MaxEIRP/Clients  Radio 2 Band Ch/EIRP/MaxEIRP/Clients
    ----                -----              ----------   -------  -----  ------   --------  ------------  ------------------------------------  ------------------------------------  ------------------------------------
    cluster02-test  SouthW-Std-InRoom  503H     E2a    17m:49s  N/A       A             AP:5GHz-HE:157/14.0/14.0/0            AP:2.4GHz-HE:11/7.0/20.0/0



  • 7.  RE: Remotely Factory Default an AP

    Posted May 22, 2023 10:07 AM

    Think I've answered my own question!

    I've been picking off APs from Airwave and hadn't realised that all the MAC addresses I worked with previoulsy were lower case, but the most recent ones from AW are upper case. It wasn't until I put these into the previous spreadsheet that I spotted this difference. The commands below work just fine for lower case MACs, but there's no error to tell you that upper case MACs don't work. So it's a bit odd that in some instances Aruba shows lower case MAC, and in others, it shows upper case. PITA when you forget this is significant for commands.