Controllerless Networks

 View Only
last person joined: 5 days ago 

Instant Mode - the controllerless Wi-Fi solution that's easy to set up, is loaded with security and smarts, and won't break your budget
Expand all | Collapse all

Sonos system not working however airgroup was enabled

This thread has been viewed 22 times
  • 1.  Sonos system not working however airgroup was enabled

    Posted May 27, 2024 07:48 PM

    Hi Guys,

    I tried to set up a Sonos system on Aruba wireless network. The problem is that Sonos devices are on SSID1 (eg. vlan10), mobile devices are on SSID2 (eg. vlan20). I read about that airgroup needed for that, so I made configurations, I checked, airgroup is working (show airgroup servers list Sonos devices), however Sonos app doesn't find Sonos devices. If I put the mobile device on the same SSID/vlan where are Sonos devices, it works of course.

    Airgroup configuration:

    airgroupservice airplay
     description AirPlay
    airgroupservice airprint
     description AirPrint
    airgroupservice Sonos
     id urn:schemas-upnp-org:service:GroupRenderingControl:1
     id urn:schemas-sonos-com:service:Queue:1
     id urn:schemas-upnp-org:service:AVTransport:1
     id urn:schemas-upnp-org:service:RenderingControl:1
     id urn:schemas-tencent-com:service:QPlay:1
     id urn:schemas-upnp-org:service:GroupManagement:1
     id urn:schemas-upnp-org:service:ZoneGroupTopology:1
     id urn:schemas-upnp-org:service:DeviceProperties:1
     id urn:schemas-upnp-org:service:MusicServices:1
     id urn:schemas-upnp-org:service:AlarmClock:1
     id urn:schemas-upnp-org:device:ZonePlayer:1
     id urn:schemas-upnp-org:service:SystemProperties:1
     id urn:schemas-upnp-org:service:ContentDirectory:1
     id urn:schemas-upnp-org:service:ConnectionManager:1
     id urn:schemas-upnp-org:service:HTControl:1
     id urn:smartspeaker-audio:service:SpeakerGroup:1
     id urn:schemas-upnp-org:service:VirtualLineIn:1
     id _sonos._tcp
     id _spotify-connect._tcp
     id _companion-link._tcp
    airgroupservice allowall

    I also set this on SSID1 and SSID2 also:

    broadcast-filter none
    multicast-rate-optimization dynamic-multicast-optimization

    xx:xx:xx:xx:xx:xx# show airgroup servers

    AirGroup Servers
    MAC                IP              Type       Host Name           Service  VLAN  Wired/Wireless  Role   Group  Name     AP-Name
    ---                --              ----       ---------           -------  ----  --------------  ----   -----  ----     -------
    aa:aa:aa:aa:aa:aa  mDNS,DLNA  Sonos-aaaaaaaaaaaa  Sonos    10    wireless        SSID1                  xx:xx:xx:xx:xx:xx
    bb:bb:bb:bb:bb:bb  DLNA                           Sonos    10    wireless        SSID1         SonosZP  xx:xx:xx:xx:xx:xx
    Num Servers: 2.


    What can be the problem?

    The S in IOT stands for Security.

  • 2.  RE: Sonos system not working however airgroup was enabled

    Posted May 27, 2024 08:19 PM

    Have you enabled DLNA and DLNA Media Service?

    If my post was useful accept solution and/or give kudos.
    Any opinions expressed here are solely my own and not necessarily that of HPE or Aruba.

  • 3.  RE: Sonos system not working however airgroup was enabled

    Posted May 28, 2024 03:23 AM

    Yes, I tried that also.

    The S in IOT stands for Security.

  • 4.  RE: Sonos system not working however airgroup was enabled

    Posted 25 days ago

    Hi Safranek, Did you solve this one as I have a similar setup ie.. Sonos on a different vlan to the users.  Also have spotify connect to get running which is a complete different issue.

    From my understanding we have to also present both vlans to the APs so the multicasts can be seen.