Wired Intelligent Edge

 View Only
last person joined: yesterday 

Bring performance and reliability to your network with the HPE Aruba Networking Core, Aggregation, and Access layer switches. Discuss the latest features and functionality of your switching devices, and find ways to improve security across your network to bring together a mobile-first solution
Expand all | Collapse all

Switch cannot join stack due to mismatch stack id

This thread has been viewed 0 times
  • 1.  Switch cannot join stack due to mismatch stack id

    Posted Dec 20, 2018 01:19 PM

    This week I tried to add a 2920-24G-PoEP (j9727A) to an existing stack of two J9728A's. The "to add switch" came out of another building and was used in another stack. I did a factory reset without the stacking module, then inserted the stacking module, powered the switch back on and enabled stacking. Connected the cables between all three switches in ring topology. All switches are running the same software WB.16.08.0001.
    In the stack the new unit is not visible by the <show stack> command. In the log file of the stack it shows the error message:  Switch with stack ID 7446a05c-xxxxx cannot join stack due to mismatch stack id

    Tried to reset the J9727A again, using serial connection but after enabeling stacking it directly adds the stacking line to the config with stacking member 1. After rebooting the two led's <cmd> and <stk> are lit and stay lit. The new switch seems to stay in commander mode.
    The config of all switches are straight on, only LACP on several ports, no VLAN's except the default one.
    Renaming the new switch is not an option as this is the only unit when powered on and stacking enabled, a rename or member number change is not valid as the error message show after trying to execute it.

    I cannot find any info on this error message, does anyone have a clue?
    Thanks in advance.



  • 2.  RE: Switch cannot join stack due to mismatch stack id

    Posted Dec 21, 2018 06:36 AM

    After a long night of trying I was able to solve the issue myself. Thanks to  parnassus I have to say with all his links to HPE support docs and his comments to it! The related info is:

    • HPE 2920 Switch Series - Stack configuration and adding new member in stack (HPE Knowledge Article: mmr_sf-EN_US000005397).
    • The one and only command which solved the issue was resetting the stack info (on the switch which was not connecting) to factory default: 
      "stacking factory-reset"
    • The command must be run on the switch which does not connect and with all stacking cables connected to the other switches (the switch cab be connected to another switch to access it via IP or use a serial connection)
    • After this the existing stack directly showed the new member had joined
    • Problem was caused by the fact that the new switch already had a Stacking ID (not to confuse with Stacking Member number 1-4). This 16 digit number in form of xxxxxxxx-xxxxxxxx, was already given to the "new" switch.

  • 3.  RE: Switch cannot join stack due to mismatch stack id

    Posted Dec 24, 2018 06:22 AM
    Glad to have indirectly helped...sorry for not being able to chime in on this thread but these days are really busy! Great you solved! Have a nice Xmas and happy new year!

  • 4.  RE: Switch cannot join stack due to mismatch stack id

    Posted Sep 29, 2021 08:05 AM

    just a minor suggestion to not do this when you are remote. In my case it caused a massive loop what brough master & slave both down

  • 5.  RE: Switch cannot join stack due to mismatch stack id

    Posted Sep 29, 2021 09:17 AM

    Hi @Jeroen_Kleen, what part (of the document) exactly caused you troubles working remotely? any operation executed remotely could potentially cause a disaster...especially dangerous when remote sites are unmanned or there is no plan B to (re)gain control over remote devices (such as having the serial console access granted and readily available or when forcing a power-off/power-on is impossible remotely)!