Wireless Access

 View Only
last person joined: 2 days ago 

Access network design for branch, remote, outdoor, and campus locations with HPE Aruba Networking access points and mobility controllers.
Expand all | Collapse all

Uploading new image file to Local Contr0ller at different office with TFTP

This thread has been viewed 10 times
  • 1.  Uploading new image file to Local Contr0ller at different office with TFTP

    Posted Mar 14, 2023 05:39 PM

    I am planning on manually updating a Managed Aruba Local Wireless Controller.  I have notes how to do it manually; but, I have not done this in a while and I have a few questions.

    If I browse to the Web User Interface and login as admin I  will navigate to: 'Maintenance' - 'Software Management' and select TFTP to transfer the image file.

    This is a remote office and  According to https://www.arubanetworks.com/techdocs/ArubaOS/Consolidated_8.x_RN/Content/commonTopics/upgrade-aos.htm make sure that my TFTP server can send the data over 30 MB.  The TFTP server will actually be my workstation.  The MPLS circuit is faster than 30 MBps  I believe i tis a 50 MB circuit.

    Quesiton1: Will it still work if I use a TFTP option to upload the Firmware for a controller upgrade?   The image file is 158,785 KB large.

    Question2:  If I do a Manual upgrade (1 controller at a time) may I use the actual file name of the file name when uploading the file or must I use a variation such as only the 'Version_Build#'?



    ------------------------------
    Stavros K
    ------------------------------


  • 2.  RE: Uploading new image file to Local Contr0ller at different office with TFTP

    EMPLOYEE
    Posted Mar 15, 2023 10:43 AM

    You can also just upload the image via the WebUI (option Local File):

    If you want to run the upgrade over the CLI, you can also do scp/http/ftp to fetch the image. I stopped using tftp years ago as it is slow, showed not fully reliable and especially with large files there are challenges (and tftp was never designed with large files in mind). The 30MB is megabytes of filesize, not the speed. Older TFTP implementations had a cap (I assume that was 30MB if you mention it) and would abort at at a certain point.

    Example for http:

    (md7005) #copy http: http://192.168.32.20:/ArubaOS_70xx_8.11.0.0_85179 system: partition 1


    ------------------------------
    Herman Robers
    ------------------------
    If you have urgent issues, always contact your Aruba partner, distributor, or Aruba TAC Support. Check https://www.arubanetworks.com/support-services/contact-support/ for how to contact Aruba TAC. Any opinions expressed here are solely my own and not necessarily that of Hewlett Packard Enterprise or Aruba Networks.

    In case your problem is solved, please invest the time to post a follow-up with the information on how you solved it. Others can benefit from that.
    ------------------------------