Controllerless Networks

Reply
Highlighted
Occasional Contributor II

How to increase the DHCP Pool???

Greetings All,

 We have Aruba controller 7210 V 6.4.4.6 and we need to know how to increase the DHCP pool instead of 252 IP's to  512 IP's.

 

I have uploaded the photos  for the current configuration 

 

Dhcp statistics.GIFDHCP.GIFPool Configuration.GIF

Re: How to increase the DHCP Pool???

I believe 7010 can scale upto 1000 leases pre 8.2 releases and 2048 post 8.2.

 

In your case, looks like you have configured the subnet to be /24, which will give you 256 IP addresses. Change it to /23 and you will get 512 IP Addresses.

JayBee
ACDX | ACCX| CCIE (RnS/SP,DC) | ACCP | ACMP | ACSA | ACMA | CWNA | JNCIS | JNCIA
If the provided solution resolves your issue, please mark it as accepted solution to help others.
Occasional Contributor II

Re: How to increase the DHCP Pool???


@Jibran.Aziz wrote:

I believe 7010 can scale upto 1000 leases pre 8.2 releases and 2048 post 8.2.

 

In your case, looks like you have configured the subnet to be /24, which will give you 256 IP addresses. Change it to /23 and you will get 512 IP Addresses.



thanks, 

 

 

 

 

 

Re: How to increase the DHCP Pool???

Try updating the scope from CLI. I had funky isuses with GUI in the past. Do a show run and look for DHCP pool section. Copy the DHCP pool config, edit with the new subnet, remove the scope and re-apply.Works like a charm.

JayBee
ACDX | ACCX| CCIE (RnS/SP,DC) | ACCP | ACMP | ACSA | ACMA | CWNA | JNCIS | JNCIA
If the provided solution resolves your issue, please mark it as accepted solution to help others.
Occasional Contributor II

Re: How to increase the DHCP Pool???

Thanks, 

 

 

 

Re: How to increase the DHCP Pool???

Should be something like:

!

interface vlan 11
no ip address
ip address 192.168.1.2 255.255.254.0
operstate up
exit
!

#Not the best DHCP pool names.
no ip dhcp pool AP's
!
ip dhcp pool AP_VLAN11
default-router 192.168.1.2
network 192.168.1.0 255.255.254.0
dns-server 10.10.50.1
authoritative
!

 

If you have any other core switch/device that is advertising VLAN 11 subnet, you have to update the subnet to /23.

 

Also noticed your VLAN 8 is /20:

interface vlan 8
ip address 172.8.1.2 255.255.240.0

 

Make sure this is by design. You won't ne able to create a DHCP scope for /20 on an Aruba controller. Try using a dedicated DHCP server for this subnet.

JayBee
ACDX | ACCX| CCIE (RnS/SP,DC) | ACCP | ACMP | ACSA | ACMA | CWNA | JNCIS | JNCIA
If the provided solution resolves your issue, please mark it as accepted solution to help others.
Occasional Contributor II

Re: How to increase the DHCP Pool???

Hi Aziz, 

 

about your noticed for VLAN8 its already working for an end user

 

 

Also noticed your VLAN 8 is /20:

interface VLAN 8
ip address 172.8.1.2 255.255.240.0

 

Make sure this is by design. You won't be able to create a DHCP scope for /20 on an Aruba controller. Try using a dedicated DHCP server for this subnet.

 

also as understand that the Aruba  controller 7210 can generate DHCP pool up to 5120  

Re: How to increase the DHCP Pool???

My bad.. I thought you are using 7010.

JayBee
ACDX | ACCX| CCIE (RnS/SP,DC) | ACCP | ACMP | ACSA | ACMA | CWNA | JNCIS | JNCIA
If the provided solution resolves your issue, please mark it as accepted solution to help others.
Occasional Contributor II

Re: How to increase the DHCP Pool???

I received the below during the configuration 

 

(NESMA) (config-subif)#no ip address

Error: Switch IP address is configured with this interface

Occasional Contributor II

Re: How to increase the DHCP Pool???

 

Also I tried to remove the vlan11 but i received the following

 

(NESMA) (config) #no interface vlan 11
ERROR: Cannot Delete Vlan Routing Interface:Remove IP Address before deleting the interface

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: