Controllerless Networks

Reply
Contributor I

Transition Master to Slave : IAP lose config ?

Hi all,

I have two IAP's. IAP 205 and 225.

I am testing the quick loss of the Master IAP, and the transparent failover of virtual controller. So i unplugged the master to simulate the loss, the other IAP become master.

When the IAP is re-plugged, as it's configured as master prefered, it returns to master state. The other IAP reboot and came up as slave. This is a normal behavior for me.

 

The problem is connectivity between master and slave is lost, i can't see slave on VC and i can't reach master from slave.

 

I think that slave came up with default wired profiles so it can't reach master because it has wired ports configured access when it's trunk on switch.

I have two solutions to retablish connectivity :

- switch config on switch to access and then to trunk when slave has sync with master

- reload slave IAP (i don't understand here why it doesn't work at the first reboot)

 

Both are annoying when u want transparent failover.

Is there a trick or something i miss on configuration to avoid this ?

Thanks for help

 

Guru Elite

Re: Transition Master to Slave : IAP lose config

Which version of IAP is this?

 


*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.3 User Guide
InstantOS 8.3 User Guide
Airheads Knowledgebase
Airheads Learning Videos
Contributor I

Re: Transition Master to Slave : IAP lose config ?

IAP-205 & IAP-225

Version : 6.4.2.6-4.1.1.11

Guru Elite

Re: Transition Master to Slave : IAP lose config ?

For the IAP that does not join back, can you paste in the output of "show log system"?


*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.3 User Guide
InstantOS 8.3 User Guide
Airheads Knowledgebase
Airheads Learning Videos
Contributor I

Re: Transition Master to Slave : IAP lose config ?

After reboot :

slave_log.png

Guru Elite

Re: Transition Master to Slave : IAP lose config ?

What is .150?


*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.3 User Guide
InstantOS 8.3 User Guide
Airheads Knowledgebase
Airheads Learning Videos
Contributor I

Re: Transition Master to Slave : IAP lose config ?

The end of IP address.

.150 is the master

.149 is the slave

Guru Elite

Re: Transition Master to Slave : IAP lose config ?

Is that the first AP or the second AP?  Who does it say is the master?


*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.3 User Guide
InstantOS 8.3 User Guide
Airheads Knowledgebase
Airheads Learning Videos
Contributor I

Re: Transition Master to Slave : IAP lose config ?

.150 is the first IAP, configured as prefered master. .149 is the other.

.150 is the one i unplugged for testing.

Guru Elite

Re: Transition Master to Slave : IAP lose config ?

It correctly says that it is the master.  You probably would need the ouput of 'show log system' on the -preferred master to see if that access point is joined by the non-preferred master.  If not, you should upgrade to the IAP code (4.2.3) that came out today to see if it makes a difference.

 


*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.3 User Guide
InstantOS 8.3 User Guide
Airheads Knowledgebase
Airheads Learning Videos
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: