Wired Intelligent Edge (Campus Switching and Routing)

Reply
Occasional Contributor I

Aruba 2930F with Cisco 1300 Bridge

We have a remote building linked with two older Cisco 1300 wireless bridges. We've replaced the older Cisco 500 switches with Aruba 2930Fs configured with data VLAN 310 and voice VLAN 311. The ports attached to the bridges are untagged VLAN 1, tagged VLAN 310, and tagged VLAN 311.  The Cisco root bridge configuration is listed below FYI but is unchanged from the original working config when we were using the Ciscos with the exception that CDP is disabled because we've had issues with Cisco WAPs registering via aruba switches when CDP is active. Traffic is not flowing between the bridges and the switches. Any help or suggestions are greatly appreciated.

 

Current configuration : 1839 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Redacted
!
ip subnet-zero
no aaa new-model
dot11 vlan-name Access vlan 330
dot11 vlan-name Cisco-Voice vlan 331
dot11 vlan-name Native vlan 1
!
dot11 ssid WCCSN
vlan 1
authentication open
infrastructure-ssid
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
ssid WCCSN
!
speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
channel 2462
station-role root bridge
!
interface Dot11Radio0.100
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
!
interface Dot11Radio0.300
encapsulation dot1Q 330
no ip route-cache
bridge-group 155
!
interface Dot11Radio0.301
encapsulation dot1Q 331
no ip route-cache
bridge-group 255
!
interface FastEthernet0
no ip address
no ip route-cache
hold-queue 80 in
!
interface FastEthernet0.100
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
!
interface FastEthernet0.300
encapsulation dot1Q 330
no ip route-cache
bridge-group 155
!
interface FastEthernet0.301
encapsulation dot1Q 331
no ip route-cache
bridge-group 255
!
interface BVI1
ip address 192.168.199.206 255.255.255.0
no ip route-cache
!
ip default-gateway 192.168.199.1
ip http server
no ip http secure-server
snmp-server community $^qaz9wsx!$ RO

no cdp run
!
control-plane
bridge 1 protocol ieee
bridge 1 route ip
bridge 155 protocol ieee
bridge 255 protocol ieee
line con 0
line vty 0 4
login local
end

MVP Expert

Re: Aruba 2930F with Cisco 1300 Bridge


@Eric Allison wrote: We've replaced the older Cisco 500 switches with Aruba 2930Fs configured with data VLAN 310 and voice VLAN 311. The ports attached to the bridges are untagged VLAN 1, tagged VLAN 310, and tagged VLAN 311.

 

Hi, can you also show us relevant configuration of those ports (on both Aruba 2930F ends) and used VLAN IDs?

Occasional Contributor I

Re: Aruba 2930F with Cisco 1300 Bridge

Thanks for the reply. This is one side with the relevant port being 2/24:

 

vlan 1
name "DEFAULT_VLAN"
no untagged 1/1-1/24,2/1-2/23
untagged 1/25-1/26,2/24-2/26
ip address dhcp-bootp
exit
vlan 310
name "VLAN310"
untagged 1/1-1/12,1/18-1/24,2/1-2/23
tagged 1/25,2/24-2/25
ip address 192.168.31.3 255.255.255.0
exit
vlan 311
name "VLAN311"
tagged 1/1-1/12,1/18-1/25,2/1-2/20,2/24-2/25
ip address 10.168.31.3 255.255.255.0
voice
exit

 

This is the other side with the relevant port being 8:

 

vlan 1
name "DEFAULT_VLAN"
no untagged 1-6
untagged 8-10
ip address dhcp-bootp
exit
vlan 310
name "VLAN310"
untagged 1-7
tagged 8
ip address 192.168.31.4 255.255.255.0
exit
vlan 311
name "VLAN311"
tagged 1-6,8
ip address 10.168.31.4 255.255.255.0
voice
exit

 

MVP Expert

Re: Aruba 2930F with Cisco 1300 Bridge

Apparently both configurations (for VLAN and Interfaces tagging) look good from untagging/tagging membership standpoint...instead I noticed a good example of Cisco IOS Software Configuration Guide for Cisco Aironet 1300 Series Outdoor Access Point/Bridge 12.3(7)JA can, as example, be found here (note how at the end of the page there is "VLAN Configuration Example" which resemble your scenario...even if in your Cisco Bridge I see only one SSID)...given that it worked flawlessly when there were Cisco 500 Switches would be then interesting to see how those were configured...just to see if a 1:1 mapping between these ones and the new Aruba 2930F switches can be inferred.

 

Can you also share the output of show spanning-tree (especially for port 2/24 and 8 of Aruba 2930F switches)?

Occasional Contributor I

Re: Aruba 2930F with Cisco 1300 Bridge

Thank You for the reference. We only need one SSID as no grouping is required. The connection supports a single office with one phone, two PCs, and a single WAP. Given my druthers, he'd move into an available office space across the road in the building that houses the root bridge, but politics.

 

The 500s both connected to the bridges on ports using the Smartport "switch" setting on VLAN 1. There is no CLI on a 500 so I can't include a running config.

 

This is the spanning-tree report for 2/24 on the root side:

2/24 100/1000T | 200000 128 Forwarding | 0018ba-5ad260 2 Yes No

 

The S-T report for port 8, on the other side, shows a similar entry that correctly lists the MAC address of that bridge unit.

 

Occasional Contributor I

Re: Aruba 2930F with Cisco 1300 Bridge

For the record, we had another Cisco wireless point claiming bridge root status, and confusing the spanning-tree connectiving within the dot11 realm.  I realized that after looking at dot11 association reports and seeing none on the "new" root.

 

So I can now confirm that point-to-point bridging, with multiple vlans, works using the Cisco outdoor 1310 configs, and the Aruba untagged/tagged settings, listed in the posts above.

 

Thank You Parnassus for the replies and references.

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: