Wired Intelligent Edge (Campus Switching and Routing)

Reply
Occasional Contributor II

Low CIR and High Drops TX during backups

Good afternoon to all, I hope your day is going well. I have an interesting issues that has plauged me for about three weeks now. I have a 250Mbps AT&T switched ethernet (ASE) Circuit that was installed about a month ago in a data center about 100 miles away from me. Ever since it was installed I have been having a lot of trouble with it. When I run IPerf against it, the best throughput I am able to achieve is 65-90 Mbps. I have another 250Mbps ASE that works perfectly fine. Both the working circuit and the ailed circuit are configured essentially the same. To add to this, while running back ups against the slower circuit, I am seeing a significant amount of Drops TX on the port. The only noticeable large differances are one uses a fiber port as the uplink and the other uses an ethernet port as an uplink. All vlan 1 traffic is for local addressing, and it is all forwarded back to a central location via a default route. The speed tests I have completed both orginionated from the same machine at the same location.  I have included snippits of the configs and show commands below: 

Bad Circuit config: 

ip route 0.0.0.0 0.0.0.0 X.X.X.X
ip routing
interface 24
rate-limit all out kbps 250000
exit
vlan 1
name "DEFAULT_VLAN"
untagged 1-23,A1-A4
tagged 24
ip address X.X.X.X 255.255.255.0
exit
vlan 339
name "VLAN339"
tagged 24
ip address X.X.X.X 255.255.255.0
exit
spanning-tree
spanning-tree force-version rstp-operation

 

Bad show int (uplink port only) 

DR-1# show int e 24

Status and Counters - Port Counters for port 24

Name :
MAC Address : ecebb8-10b768
Link Status : Up
Totals (Since boot or last clear) :
Bytes Rx : 1,934,220,284 Bytes Tx : 1,020,228,678
Unicast Rx : 38,933,610 Unicast Tx : 24,699,894
Bcast/Mcast Rx : 1,396,441 Bcast/Mcast Tx : 361
Errors (Since boot or last clear) :
FCS Rx : 0 Drops Tx : 3,228
Alignment Rx : 0 Collisions Tx : 0
Runts Rx : 0 Late Colln : 0
Giants Rx : 0 Excessive Colln : 0
Total Rx Errors : 0 Deferred Tx : 0
Others (Since boot or last clear) :
Discard Rx : 0 Out Queue Len : 0
Unknown Protos : 0
Rates (5 minute weighted average) :
Total Rx (bps) : 58,154,168 Total Tx (bps) : 6,656,032
Unicast Rx (Pkts/sec) : 5,375 Unicast Tx (Pkts/sec) : 3,110
B/Mcast Rx (Pkts/sec) : 262 B/Mcast Tx (Pkts/sec) : 0
Utilization Rx : 05.81 % Utilization Tx : 00.66 %

 

Bad Show int bri (uplink port only) 

24 100/1000T | No Yes Up 1000FDx MDI off 0

 

Below this line is the good configs 

 

Good Config: 

ip route 0.0.0.0 0.0.0.0 X.X.X.X
ip routing
interface A1
rate-limit all out kbps 250000
exit

vlan 1
name "DEFAULT_VLAN"
no untagged 23
untagged 1-22
tagged 24,A1-A4
ip address X.X.X.X 255.255.255.0

vlan 339
name "VLAN339"
tagged A1
ip address X.X.X.X 255.255.255.0
exit
spanning-tree
spanning-tree force-version rstp-operation

 

Good Show int (uplink port only) 

Status and Counters - Port Counters for port A1

Name :
MAC Address : 94f128-3ec866
Link Status : Up
Totals (Since boot or last clear) :
Bytes Rx : 1,586,525,170 Bytes Tx : 1,955,749,768
Unicast Rx : 10,759,389 Unicast Tx : 8,007,591
Bcast/Mcast Rx : 6,114,765 Bcast/Mcast Tx : 677,618
Errors (Since boot or last clear) :
FCS Rx : 0 Drops Tx : 282
Alignment Rx : 0 Collisions Tx : 0
Runts Rx : 0 Late Colln : 0
Giants Rx : 0 Excessive Colln : 0
Total Rx Errors : 0 Deferred Tx : 0
Others (Since boot or last clear) :
Discard Rx : 0 Out Queue Len : 0
Unknown Protos : 0
Rates (5 minute weighted average) :
Total Rx (bps) : 573,016 Total Tx (bps) : 160,128
Unicast Rx (Pkts/sec) : 67 Unicast Tx (Pkts/sec) : 43
B/Mcast Rx (Pkts/sec) : 222 B/Mcast Tx (Pkts/sec) : 21
Utilization Rx : 00.05 % Utilization Tx : 00.01 %

 

Good show int bri (uplink port only) 

A1 1000SX | No Yes Up 1000FDx NA off 0

 

 

 

MVP Expert

Re: Low CIR and High Drops TX during backups

Switch models and software versions?
Occasional Contributor II

Re: Low CIR and High Drops TX during backups

The switch models are both Aruba 3810M (Jl073X). 

 

The bad switch is on firmware version KB.16.06.0009

The good switch is on firmware version KB.16.05.0007 

Super Contributor II

Re: Low CIR and High Drops TX during backups

The number of drops at the switch is really low. Could it be possible that there is an issue with the circuit?


Willem Bargeman ACMX#935 | ACCX #822

Please give me kudos if my post was useful!
If your issue is solved mark the post as solution!
Occasional Contributor II

Re: Low CIR and High Drops TX during backups

Thats my thoughts too, but I have fought with AT&T for days to get them to check it. They said every hop along the way is showing the correct throughput, including to their device at the remote location. They told me their device was showing 220 Mb throughput at times. The only thing I can think of that I  have not tried is moving the uplink port from port 24 to another port, and asking the datacenter to check the cable in between my equipment and AT&T, but I have not done that yet because I am still getting Solid traffic to my switch, its just slower than its supposed to be and occasionally has TX drops. does anyone think a bad layer one could be the cause? 

Highlighted
Occasional Contributor II

Re: Low CIR and High Drops TX during backups

Ran a single backup last night. It was my exchange server. The back up finished, but it took about 8 hours, and this was the results of the show int this morning 

 

Port: 24

Total Bytes: 1,507,117,687

Total Frames: 887,010,432

Errors RX: 0

Drops TX: 17,076

Flow Control: off

Bcast Limit: 0

Super Contributor II

Re: Low CIR and High Drops TX during backups

There are just a few TX drops. I don't suspect issues because of this drops.

 

Is it possible to connect directly to the AT&T router and do a iperf from there?


Willem Bargeman ACMX#935 | ACCX #822

Please give me kudos if my post was useful!
If your issue is solved mark the post as solution!
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: