Wired Intelligent Edge (Campus Switching and Routing)

Reply
Highlighted
Occasional Contributor I

Please help add aruba switch (2930f and 5406zl) to HPIMC

Hello everybody,

Is now, I need to add some HP Switch (Aruba 2930F and Aruba 5406) to HPIMC. But when add have an error

On Aruba 2930F: 

2930F.PNG

 

 

 

 

 

 

I sure, ssh username and password are correct. 

With HP 5406ZL

5406 info.PNG5406.PNG

And  this is my config on Aruba 2930F:


Running configuration:

; JL253A Configuration Editor; Created on release #WC.16.03.0005
; Ver #10:08.3f.ff.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:7e
hostname "m_b3.1_a1"
module 1 type jl253a
aruba-central disable
no rest-interface
trunk 25-26 trk22 lacp
trunk 27 trk32 lacp
igmp lookup-mode ip
logging 10.129.50.248 udp 10001
logging origin-id hostname
timesync sntp
sntp unicast
sntp server priority 1 10.129.50.10
sntp server priority 2 10.129.50.11
no telnet-server
time daylight-time-rule western-europe
time timezone 420
no web-management
ip default-gateway 10.129.188.1
interface 25
name "-i- m_b_dc_c"
exit
interface 26
name "-i- m_b_dc_c"
exit
interface 27
name "-i- m_dr_c"
exit
snmp-server community "kafka" operator
aaa authorization commands local
aaa authentication local-user "abc" group "Level-15"
vlan 1
name "DEFAULT_VLAN"
no untagged 1-24
untagged 28,Trk22,Trk32
no ip address
exit
vlan 192
name "MEDIA-NET"
untagged 1-21,23-24
tagged 22,Trk22,Trk32
ip address 192.168.195.22 255.255.252.0
ip igmp
no ip igmp querier
ip igmp version 3
exit
vlan 410
name "Mgmt"
tagged Trk22,Trk32
ip address 10.129.188.13 255.255.255.0
exit
vlan 1000
name "CASINO-NET"
tagged Trk22,Trk32
no ip address
exit
spanning-tree
spanning-tree 1 admin-edge-port
spanning-tree 1 bpdu-protection
spanning-tree 2 admin-edge-port
spanning-tree 2 bpdu-protection
spanning-tree 3 admin-edge-port
spanning-tree 3 bpdu-protection
spanning-tree 4 admin-edge-port
spanning-tree 4 bpdu-protection
spanning-tree 5 admin-edge-port
spanning-tree 5 bpdu-protection
spanning-tree 6 admin-edge-port
spanning-tree 6 bpdu-protection
spanning-tree 7 admin-edge-port
spanning-tree 7 bpdu-protection
spanning-tree 8 admin-edge-port
spanning-tree 8 bpdu-protection
spanning-tree 9 admin-edge-port
spanning-tree 9 bpdu-protection
spanning-tree 10 admin-edge-port
spanning-tree 10 bpdu-protection
spanning-tree 11 admin-edge-port
spanning-tree 11 bpdu-protection
spanning-tree 12 admin-edge-port
spanning-tree 12 bpdu-protection
spanning-tree 13 admin-edge-port
spanning-tree 13 bpdu-protection
spanning-tree 14 admin-edge-port
spanning-tree 14 bpdu-protection
spanning-tree 15 admin-edge-port
spanning-tree 15 bpdu-protection
spanning-tree 16 admin-edge-port
spanning-tree 16 bpdu-protection
spanning-tree 17 admin-edge-port
spanning-tree 17 bpdu-protection
spanning-tree 18 admin-edge-port
spanning-tree 18 bpdu-protection
spanning-tree 19 admin-edge-port
spanning-tree 19 bpdu-protection
spanning-tree 20 admin-edge-port
spanning-tree 20 bpdu-protection
spanning-tree 21 admin-edge-port
spanning-tree 21 bpdu-protection
spanning-tree 22 admin-edge-port
spanning-tree 22 bpdu-protection
spanning-tree 23 admin-edge-port
spanning-tree 23 bpdu-protection
spanning-tree 24 admin-edge-port
spanning-tree 24 bpdu-protection
spanning-tree Trk22 priority 4
spanning-tree Trk32 priority 4
spanning-tree priority 15
no tftp server
no autorun
no dhcp config-file-update
no dhcp image-file-update
no dhcp tr69-acs-url
password manager
password operator

 

Please help me fix this problem.

Thanks and regards, 

 

 


Accepted Solutions
Highlighted
Occasional Contributor I

Re: Please help add aruba switch (2930f and 5406zl) to HPIMC

On HPIMC, ssh/snmp templates config is correct. 

On Switch 5130,5940 everything is ok. The problem only Aruba switch

And after I remove the password operator by cli: no password operator. HPIMC can be backup.

Thanks everyone, 

 

View solution in original post


All Replies
Highlighted
MVP Guru Elite

Re: Please help add aruba switch (2930f and 5406zl) to HPIMC


@voducduy wrote:

Hello everybody,

Is now, I need to add some HP Switch (Aruba 2930F and Aruba 5406) to HPIMC. But when add have an error

On Aruba 2930F: 

2930F.PNG

 

 

 

 

 

 

I sure, ssh username and password are correct. 

With HP 5406ZL

5406 info.PNG5406.PNG

And  this is my config on Aruba 2930F:


Running configuration:

; JL253A Configuration Editor; Created on release #WC.16.03.0005
; Ver #10:08.3f.ff.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:7e
hostname "m_b3.1_a1"
module 1 type jl253a
aruba-central disable
no rest-interface
trunk 25-26 trk22 lacp
trunk 27 trk32 lacp
igmp lookup-mode ip
logging 10.129.50.248 udp 10001
logging origin-id hostname
timesync sntp
sntp unicast
sntp server priority 1 10.129.50.10
sntp server priority 2 10.129.50.11
no telnet-server
time daylight-time-rule western-europe
time timezone 420
no web-management
ip default-gateway 10.129.188.1
interface 25
name "-i- m_b_dc_c"
exit
interface 26
name "-i- m_b_dc_c"
exit
interface 27
name "-i- m_dr_c"
exit
snmp-server community "kafka" operator
aaa authorization commands local
aaa authentication local-user "abc" group "Level-15"
vlan 1
name "DEFAULT_VLAN"
no untagged 1-24
untagged 28,Trk22,Trk32
no ip address
exit
vlan 192
name "MEDIA-NET"
untagged 1-21,23-24
tagged 22,Trk22,Trk32
ip address 192.168.195.22 255.255.252.0
ip igmp
no ip igmp querier
ip igmp version 3
exit
vlan 410
name "Mgmt"
tagged Trk22,Trk32
ip address 10.129.188.13 255.255.255.0
exit
vlan 1000
name "CASINO-NET"
tagged Trk22,Trk32
no ip address
exit
spanning-tree
spanning-tree 1 admin-edge-port
spanning-tree 1 bpdu-protection
spanning-tree 2 admin-edge-port
spanning-tree 2 bpdu-protection
spanning-tree 3 admin-edge-port
spanning-tree 3 bpdu-protection
spanning-tree 4 admin-edge-port
spanning-tree 4 bpdu-protection
spanning-tree 5 admin-edge-port
spanning-tree 5 bpdu-protection
spanning-tree 6 admin-edge-port
spanning-tree 6 bpdu-protection
spanning-tree 7 admin-edge-port
spanning-tree 7 bpdu-protection
spanning-tree 8 admin-edge-port
spanning-tree 8 bpdu-protection
spanning-tree 9 admin-edge-port
spanning-tree 9 bpdu-protection
spanning-tree 10 admin-edge-port
spanning-tree 10 bpdu-protection
spanning-tree 11 admin-edge-port
spanning-tree 11 bpdu-protection
spanning-tree 12 admin-edge-port
spanning-tree 12 bpdu-protection
spanning-tree 13 admin-edge-port
spanning-tree 13 bpdu-protection
spanning-tree 14 admin-edge-port
spanning-tree 14 bpdu-protection
spanning-tree 15 admin-edge-port
spanning-tree 15 bpdu-protection
spanning-tree 16 admin-edge-port
spanning-tree 16 bpdu-protection
spanning-tree 17 admin-edge-port
spanning-tree 17 bpdu-protection
spanning-tree 18 admin-edge-port
spanning-tree 18 bpdu-protection
spanning-tree 19 admin-edge-port
spanning-tree 19 bpdu-protection
spanning-tree 20 admin-edge-port
spanning-tree 20 bpdu-protection
spanning-tree 21 admin-edge-port
spanning-tree 21 bpdu-protection
spanning-tree 22 admin-edge-port
spanning-tree 22 bpdu-protection
spanning-tree 23 admin-edge-port
spanning-tree 23 bpdu-protection
spanning-tree 24 admin-edge-port
spanning-tree 24 bpdu-protection
spanning-tree Trk22 priority 4
spanning-tree Trk32 priority 4
spanning-tree priority 15
no tftp server
no autorun
no dhcp config-file-update
no dhcp image-file-update
no dhcp tr69-acs-url
password manager
password operator

 

Please help me fix this problem.

Thanks and regards, 

 

 


Hi,

 

Set the login type to SSH on IMC



PowerArubaSW: Powershell Module to use Aruba Switch API for Vlan, VlanPorts, LACP, LLDP... More info

PowerArubaCP: Powershell Module to use ClearPass API (create NAD, Guest...) More info

PowerArubaCX: Powershell Module to use ArubaCX API (get interface/vlan/ports info)

PowerArubaIAP: Powershell Module to use Aruba Instant AP

PowerArubaMC: Powershell Module to use Mobility Controller / Master


ACMP 6.4 / ACMX #107 / ACCP 6.5 / ACSP
Highlighted
Occasional Contributor I

Re: Please help add aruba switch (2930f and 5406zl) to HPIMC

I known, i set ssh on IMC before

2930F-snmp.PNG

Highlighted
MVP Guru Elite

Re: Please help add aruba switch (2930f and 5406zl) to HPIMC

and always no working ?



PowerArubaSW: Powershell Module to use Aruba Switch API for Vlan, VlanPorts, LACP, LLDP... More info

PowerArubaCP: Powershell Module to use ClearPass API (create NAD, Guest...) More info

PowerArubaCX: Powershell Module to use ArubaCX API (get interface/vlan/ports info)

PowerArubaIAP: Powershell Module to use Aruba Instant AP

PowerArubaMC: Powershell Module to use Mobility Controller / Master


ACMP 6.4 / ACMX #107 / ACCP 6.5 / ACSP
Highlighted
MVP Guru

Re: Please help add aruba switch (2930f and 5406zl) to HPIMC

Where are snmp related settings on posted switch running configuration? I mean...the only reference we see is "snmp-server community "kafka" operator" ...don't get me wrong but to connect to HPE IMC using SNMP (and SSH) you should enter few more commands, isn't it?

Highlighted
Occasional Contributor II

Re: Please help add aruba switch (2930f and 5406zl) to HPIMC

First verify ssh and snmp profiles from imc.
Since you are not using tftp on switch side for file transfer you have to modify imc side as well to use sftp.
Highlighted
Occasional Contributor II

Re: Please help add aruba switch (2930f and 5406zl) to HPIMC

hope This video will help you
https://youtu.be/LufZ-qUHN-c
Highlighted
Occasional Contributor I

Re: Please help add aruba switch (2930f and 5406zl) to HPIMC

On HPIMC, ssh/snmp templates config is correct. 

On Switch 5130,5940 everything is ok. The problem only Aruba switch

And after I remove the password operator by cli: no password operator. HPIMC can be backup.

Thanks everyone, 

 

View solution in original post

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: