Wired Intelligent Edge (Campus Switching and Routing)

Reply
Occasional Contributor I

Switchport config

Hi there,

 

I'm migrating from Cisco switch to Aruba switch 3810. How can I configure the interface in Aruba switch for this config in cisco :

 

interface GigabitEthernet1/1
switchport access vlan 64
switchport trunk native vlan 64
switchport trunk allowed vlan 64
switchport mode access

MVP Expert

Re: Switchport config

Greetings!

 

Most VLAN configuration on ArubaOS-Switch is performed in the VLAN context rather than at the interface context. For example, to create VLAN 64 and assign it to interface 1 as an access (or "untagged") VLAN:

 

switch(config)# vlan 64
switch(vlan-64)# untagged 1

Once a VLAN has been created, you also have the option of performing VLAN assignments from the interface context, as in the following examples:

 

switch(config)# interface 2-8 untagged vlan 64
switch(config)# interface 24 tagged vlan 64

 



Matt Fern
Technical Marketing Engineer, Wired Intelligent Edge

Aruba, a Hewlett Packard Enterprise company

8000 FOOTHILLS BLVD  |  ROSEVILLE, CA 95747
T: 916.540.1759  |  E: mfern@hpe.com   |   Matt @ Twitter
Occasional Contributor I

Re: Switchport config

Thank you so much for your reply; if you could help which exactly the config I should use in Aruba-OS switch for Cisco the example as I'm still confused!
interface GigabitEthernet1/1
switchport access vlan 64
switchport trunk native vlan 64
switchport trunk allowed vlan 64
switchport mode access

Will VLAN 64 be tagged or untagged, what about native VLAN 64? Allowed VLAN64?
MVP Expert

Re: Switchport config

Maybe I'm wrong but

 

interface GigabitEthernet1/1
  switchport access vlan 64
  switchport trunk native vlan 64
  switchport trunk allowed vlan 64
  switchport mode access

is a pretty strange interface configuration (read, as example, here).

 

Is the Interface 1/1 set in Access mode (in Cisco jargon) or is it set with Trunk mode (again, in Cisco jargon)?

 

You shouldn't have both, Access and Trunk...it is Access or Trunk.

 

If the Interface 1/1 is set in Access mode (so the switchport mode access is valid) then this would translate into what @Matthew wrote first above:

 

switch(config)# vlan 64
switch(vlan-64)# untagged 1

or, from the interface 1 standpoint, just the very same:

 

switch(config)# interface 1 untagged vlan 64

If, instead, your Interface 1/1 is set in Trunk mode (switchport mode trunk) then this translates into:

 

switch(config)# interface 1 tagged vlan 64

implying that Interface 1 is STILL untagged member of VLAN 1 (Default) but is now tagged member of VLAN 64...so this means it can transport VLAN 64 tagged packets.

 

Cisco side:

 

Potentially...you config would be - if interconnecting to Switches and passing JUST one VLAN (your VLAN 64):

 

interface 1/1
switchport encapsulation dot1q
switchport mode trunk
switchport trunk native vlan 64
switchport trunk allowed vlan 64

With this configuration VLAN 64 will be untagged on Interface 1/1 (note the native) and will also be the only one VLAN allowed to be transported through it (note the allowed) ...but, generally, the Trunk mode is often used when you want a switch interface - logical of physical - to carry MULTIPLE concurrent VLANs between two peer Switches (or between a Switch and a Host capable of VLAN tagging), not just simply one...still that is totally possible.

Highlighted
Occasional Contributor I

Re: Switchport config

Alright then, what about this inteface which vlan should be tagged or untagged : (is VLAN 119 should be untagged)?

 

interface FastEthernet0/3
description DATA & VOICE PORT
switchport trunk native vlan 119
switchport trunk allowed vlan 10,119
switchport mode trunk
priority-queue out
spanning-tree portfast

MVP Expert

Re: Switchport config

What you set untagged for vlan it is allowed with tag...




PowerArubaSW: Powershell Module to use Aruba Switch API for Vlan, VlanPorts, LACP, LLDP... More info


PowerArubaCP: Powershell Module to use ClearPass API (create NAD, Guest...) More info


PowerArubaCX: Powershell Module to use ArubaCX API (get interface/vlan/ports info)


PowerArubaIAP: Powershell Module to use Aruba Instant AP




ACMP 6.4 / ACMX #107 / ACCP 6.5
Frequent Contributor I

Re: Switchport config

Please be aware that cisco and aruba differ in the terms of vlan tagging.

 

You need to make sure if your connected device needs a vlan tag (example uplink or most VoiP phones), or if it needs access to the vlan without tagging (untagged). 

 

Cisco's defintion is:

Trunk - A port enabled for VLAN tagging

Access - A port that does not tag and only accepts a single VLAN

 

 

----------Aruba ACCX #748, ACDX #758, ACMP, ACEAP | HPE Master ASE----------
Feel free to give kudos or accept as a solution!
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: