Wired Intelligent Edge (Campus Switching and Routing)

Reply
Highlighted
New Contributor

Vlan Problems with Aruba 2930F 24g

Hello, 

 

We currently have an issue with an Aruba 2930F.

We have 7 Vlans on this switch and have an issue with one of the Vlans.

 

When the vlan is tagged on the port that has the uplink to the rest of the network, the vlan stops working on the switch.

When the port with the uplink issnt tagged or has the vlan disabled on the port, then the vlan works whithout issues.

 

We want to use Vlan55 for our new telephone system. the device is connected to port 12 which is untagged in vlan55, this also provides DHCP for this vlan.

 

It all works when i connect the phone on a tagged port 55 (the phone is configured to use vlan 55). the phone receives an IP address and is able to make a call.

 

When i tag port 28 which is the port that connects to our main server room, the vlan stops working.

The phone connected to the switch is unable to connect to its provider.

 

When the port is set to forbidden vlan 55 it all works again.

Config of the switch below.

 

 

 

 

config:

; JL253A Configuration Editor; Created on release #WC.16.04.0018
; Ver #11:10.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:bc
hostname "SW01-INTERNET"
module 1 type jl253a
interface 2
name "Fortigate"
exit
interface 8
name "DMZ"
exit
interface 18
name "WAN"
exit
interface 28
name "SFP to serverroom"
exit
vlan 1
name "DEFAULT_VLAN"
no untagged 4,7-9,11-12,14-18
untagged 1-3,5-6,10,13,19-27
tagged 28
no ip address
forbid 11-12
exit
vlan 2
name "Internet-2"
untagged 7
tagged 2
no ip address
forbid 11-12
exit
vlan 3
name "LAN"
untagged 4,9,14,16-17
tagged 23,25-28
ip address 172.18.4.53 255.255.255.0
forbid 11-12
exit
vlan 4
name "DMZ"
untagged 8
tagged 25-28
no ip address
forbid 11-12
exit
vlan 5
name "Tel LAN old"
tagged 21,23,25-28
no ip address
forbid 11-12
exit
vlan 6
name "Internet 1"
untagged 18
tagged 25-28
no ip address
forbid 11-12
exit
vlan 55
name "Tel LAN new"
untagged 12,15
tagged 11,23,25-27
no ip address
forbid 28
exit
no tftp server
no autorun
no dhcp config-file-update
no dhcp image-file-update
no dhcp tr69-acs-url
password manager
password operator

 

 


Accepted Solutions
Highlighted
New Contributor

Re: Vlan Problems with Aruba 2930F 24g

I have found that the problem was due to a spanning tree mismatch/.

 

when i disable spanning tree on the core switch the VLAN 55 started working.

 

i will plan to implement spanning tree again later on this year

View solution in original post


All Replies
Highlighted
MVP Guru

Re: Vlan Problems with Aruba 2930F 24g

What is the VLANs tagging configuration on the uplink peer port (the port of Server Room your Interface 28 is connected to)?

Tip: generally Voice dedicated VLAN must be set of type "voice": your VLAN isn't.

Question: why Interface 28 is a tagged member of VLAN 1 (Default VLAN)?
Highlighted
New Contributor

Re: Vlan Problems with Aruba 2930F 24g

Hi Sorry for the late reply.

 

The VLAN Tagging on the uplink peer port is the same as on port 28.

is has all the vlans tagged.

 

We do not use VLAN 1 on this part of the network therefor we have no ports untagged  on this switch.

 

the vlan will be set to voice when everything is working. for now this should not be an issue.

 

I'm still confused what causes VLAN 55 to stop working on the switch when it is connected to the uplink port 28.

Is there any logging i can check to what happens to the vlans on the different ports.

Highlighted
MVP Guru

Re: Vlan Problems with Aruba 2930F 24g

Why (to) forbid 28 on VLAN 55 context?
Highlighted
New Contributor

Re: Vlan Problems with Aruba 2930F 24g

it has been set to forbid te test if the vlan works if just jused on the switch.

 

When port 28 doest have vlan 55 of has vlan 55 on forbid, then it works.

When port 28 has vlan tagged it stops working.

 

so the moment vlan 55 is used on the fibre port to our core switches (port 28) then vlan 55 stops working

 

Highlighted
MVP Guru

Re: Vlan Problems with Aruba 2930F 24g


@stefanM wrote: The VLAN Tagging on the uplink peer port is the same as on port 28. is has all the vlans tagged.

 

Well...I must admit I am not always able to follow you...can you simply show us the ACTUAL (running configuration) of VLAN 55's context grabbed on both ends (Aruba 2930F side and Core side)?

 

Just to clear any doubts...

 

Are you so kind to share the output of show vlan port 28 detail CLI command executed on Aruba 2930F and the same command relevant to your Core related to the port Id used on that side?

 

AFAIK when you set forbid x at VLAN Id y context level on the Aruba 2930F...it just means that you're preventing the port x from joining the VLAN Id y...if so you can't then ask why things go so blue.

Highlighted
New Contributor

Re: Vlan Problems with Aruba 2930F 24g

I have found that the problem was due to a spanning tree mismatch/.

 

when i disable spanning tree on the core switch the VLAN 55 started working.

 

i will plan to implement spanning tree again later on this year

View solution in original post

Highlighted
MVP Guru

Re: Vlan Problems with Aruba 2930F 24g

Glad you auto-solved.

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: