Wireless Access

Reply
Occasional Contributor II

Aruba Controller Special Characters

Hi All,

 

Recently a pair of Aruba 7210s was installed, which are running alongside a pair of Juniper controllers, providing the same SSIDs to 2 different areas.

On the Aruba Controllers there seem to be certain characters in the WPA PSK that would prevent clients from connecting…the characters are £ ‘ “

The obvious answer would be to change the PSK, but the PSK was already embedded into hundreds of laptops and mobile classrooms equipment, so it would be quite a challenge to change to PSK on all these devices, so if possible I would like to avoid this option.

 

Kind Regards,

Rieyaad

Guru Elite

Re: Aruba Controller Special Characters

You should go on the commandline of the controller and see exactly what is stored:

 

 

encrypt disable

show wlan ssid-profile <ssid profile>

 


*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.3 User Guide
InstantOS 8.3 User Guide
Airheads Knowledgebase
Airheads Learning Videos
Occasional Contributor II

Re: Aruba Controller Special Characters

Hi Colin,

 

Thanks for the response.

 

Can you explain what I am looking for?

 

Kind Regards,

Guru Elite

Re: Aruba Controller Special Characters

You are looking for the WPA passphrase to see how the PSK is stored to see if your key was accepted properly.  It seems like the special characters (not accepted for a PSK) are:

 

+\"$&`<>?'

 


*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.3 User Guide
InstantOS 8.3 User Guide
Airheads Knowledgebase
Airheads Learning Videos
Guru Elite

Re: Aruba Controller Special Characters


Rieyaad wrote:

Hi All,

 

Recently a pair of Aruba 7210s was installed, which are running alongside a pair of Juniper controllers, providing the same SSIDs to 2 different areas.

On the Aruba Controllers there seem to be certain characters in the WPA PSK that would prevent clients from connecting…the characters are £ ‘ “

The obvious answer would be to change the PSK, but the PSK was already embedded into hundreds of laptops and mobile classrooms equipment, so it would be quite a challenge to change to PSK on all these devices, so if possible I would like to avoid this option.

 

Kind Regards,

Rieyaad


When you say "I would like to avoid this option", what do you mean?


*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.3 User Guide
InstantOS 8.3 User Guide
Airheads Knowledgebase
Airheads Learning Videos
Occasional Contributor II

Re: Aruba Controller Special Characters

Hi Colin,

 

Besides changing my passphrase, is there another way the controller will accept my passphrase or is the only way around this issue is to change the passphrase?

Guru Elite

Re: Aruba Controller Special Characters

Unfortunately you will have to change the passphrase.  You could also take the opportunity to migrate to 802.1x where each user instead inputs their own username and password for access to the network.


*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.3 User Guide
InstantOS 8.3 User Guide
Airheads Knowledgebase
Airheads Learning Videos
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: