Wireless Access

Occasional Contributor II

Can't connect an AP through an S2500

I've just installed a new S2500 switch, hooked it up to my core stach (which is Cisco). I did the initial setup config and set up the initial default vlan. Since I only want the one vlan on this particular switch, I stopped there.


If I plug into the switch with my laptop, I pull a DHCP address, I can get out to the internet, I can pull up the aruba controller.


When I plug an access point into the same port on the switch, I get nothing. It powers up, the link shows as up. The DHCP server shows a lease issued in the correct subnet. It just never fully boots because it's not finding the controller. If I plug the AP into a different switch, it boots, loads, and talks just fine.


AP is a 225, switch is brand new. Any suggestions for what to check next?

Guru Elite

Re: Can't connect an AP through an S2500

Are you using a trusted or untrusted port for the AP/laptop?

Show interface-config gigabitethernet x/y/z

Tim Cappalli | Aruba Security
@timcappalli | timcappalli.me | ACMX #367 / ACCX #480
Occasional Contributor II

Re: Can't connect an AP through an S2500

Interface Trusted Mode is enabled for all of the gig ports by default, so yes. It's trusted.

Re: Can't connect an AP through an S2500


Can you console in the AP and see what's going on ?

Thank you

Victor Fabian
Lead Mobility Architect @WEI

Re: Can't connect an AP through an S2500


Did you get this working?


One other idea, see if you see any change in behavior if you enable portfast on the interface.


Best regards,



Occasional Contributor II

Re: Can't connect an AP through an S2500

Well... I finally figured it out. 


In the DHCP scope for the vlan that this switch is using, there was no 003 Router option defined, so no default gateway. 


Comparing the console output of the AP from the broken vlan to a working vlan showed that when it pulled an IP, there was no DG listed.


Adding the 003 option on the DHCP server solved the problem.


Why the laptop worked on DHCP in the same vlan, I don't understand.


This is what I get for using an old utility vlan that I created years ago and didn't bother fully re-checking, assuming I had set it up completely in the first place.



Search Airheads
Showing results for 
Search instead for 
Did you mean: