Wireless Access

Reply
New Contributor

Captive Portal issues

We have external captive portal at Library HQ. Where it is connected to branch. When user connects to wi-fi they get IP and DNS info on their device for association and then re-directs to Captive portal website and they just have to click on "Accept" on terms and conditions page appears. Now, the problem we have is users get that page more than twice. Some get it like 3-4 time, all they have to click Accept 3-4 times to browse internet.

 

Steps taken: We have replaced AP, but no luck.

Re: Captive Portal issues

Assuming your using ClearPass for the page?

 

When the user clicks "Accept" does it look like it's logging them in, or is the button not working on the page? 

 

In a normal scenario, the user clicks "Accept" and the browser then submits the request to the device configured in your page config, the controller then sources a RADIUS request to ClearPass and the user is given full access. 

 

It's possible that the login is happening faster then the controller can source the request and the user is then landing back on the page. Can you try adding a login delay of 3 seconds and see if that helps?



Michael Haring
If my answer is helpful, a Kudos is always appreciated!
New Contributor

Re: Captive Portal issues

I am consfuse here because this issue was never there with the same setup. I did not change anything on server or aruba for age out time delayed it to 2 sec but what did was I changed metatag content time on Captive portal HTML webpage which is probably designed by Library IT people hosted on external server. 

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: