Wireless Access

Reply
Highlighted
Occasional Contributor II

How to configure an internal DHCP-server with VLAN

Hi everyone,

I need a some help with the internal DHCP-server of an Aruba controller 3200. My problem is the implementation of the DHCP-server and the assosiated VLAN and/or VLAN group.

This is the first time I am working with this kind of hardware and wireless networks in general. Even though I have read quite a bit about it, I still have trouble understanding exactly what the purpose of VLANs is.


The network that I want to set up, consists of an Aruba 3200 controller, an AP 175 as a mesh portal and an AP 175 as well as an IAP 105 as mesh points. The controller as well as the AP 175 mesh portal are working as intended, but the other APs do not recieve an IP address, because they cannot find the needed DHCP server.
I tried to configure the DHCP server and an assosiated VLAN, but it simply doesn't work.
How should I configure these two? Do I need more than one VLAN? The Tutorials I found were not very helpful, only stating which inputs I have to provide, but not what they should look like or what their purpose is.

My attempt was an IPv4 DHCP-server (I am not sure whether it would be better to use an IPv6 or IPv4 DHCP-server).
Thank you very much for your efforts.


Jan


Accepted Solutions
Highlighted

Re: How to configure an internal DHCP-server with VLAN

First thing to keep in mind is that the controller acts similar to a switch/router. Think of the GRE tunnel from the AP to the controller as a physical patch cable from the client to the switch.

 

The purpose of VLANs on the controller is to pass that VLAN to the switch upstream and allow for routing to take place of the different VLANs. In many cases, VLANs are used for network segmentation and QoS. 

 

When you use the DHCP server on the Aruba Controller, ensure the controller has the VLAN ID defined, as well as an IP address assigned to that VLAN. Then you can create a DHCP scope (IPv4 is easiest) with the same network and subnet as the VLAN ID. If you want the controller to also be the gateway, ensure you allow NAT on the IP interface, otherwise let the the router (if you have one) route the traffic.



Michael Haring
If my answer is helpful, a Kudos is always appreciated!

View solution in original post

Highlighted
MVP Guru

Re: How to configure an internal DHCP-server with VLAN

With the following code you can:

- Create a VLAN (79 in the example)

- Put IP address on the VLAN

- Create a DHCP scope (pool)

- Set pool exceptions (IP addresses will not be pulled from the configured ranges)

- Enable DHCP server

vlan 79
interface vlan 79
  ip address 192.168.79.1 255.255.255.0
!
ip dhcp pool VLAN_79
 default-router 192.168.79.1
 dns-server 1.1.1.1 1.0.0.1
 domain-name aruba.local
 network 192.168.79.0 255.255.255.0

!
ip dhcp excluded-address 192.168.79.0 192.168.79.127
ip dhcp excluded-address 192.168.79.192 192.168.79.255
service dhcp

In general, use external DHCP servers wherever possible. Internal DHCP can be used for testing or small-scale deployments.

--
If you have urgent issues, please contact your Aruba partner or Aruba TAC (click for contact details).

View solution in original post


All Replies
Highlighted

Re: How to configure an internal DHCP-server with VLAN

First thing to keep in mind is that the controller acts similar to a switch/router. Think of the GRE tunnel from the AP to the controller as a physical patch cable from the client to the switch.

 

The purpose of VLANs on the controller is to pass that VLAN to the switch upstream and allow for routing to take place of the different VLANs. In many cases, VLANs are used for network segmentation and QoS. 

 

When you use the DHCP server on the Aruba Controller, ensure the controller has the VLAN ID defined, as well as an IP address assigned to that VLAN. Then you can create a DHCP scope (IPv4 is easiest) with the same network and subnet as the VLAN ID. If you want the controller to also be the gateway, ensure you allow NAT on the IP interface, otherwise let the the router (if you have one) route the traffic.



Michael Haring
If my answer is helpful, a Kudos is always appreciated!

View solution in original post

Highlighted
MVP Guru

Re: How to configure an internal DHCP-server with VLAN

With the following code you can:

- Create a VLAN (79 in the example)

- Put IP address on the VLAN

- Create a DHCP scope (pool)

- Set pool exceptions (IP addresses will not be pulled from the configured ranges)

- Enable DHCP server

vlan 79
interface vlan 79
  ip address 192.168.79.1 255.255.255.0
!
ip dhcp pool VLAN_79
 default-router 192.168.79.1
 dns-server 1.1.1.1 1.0.0.1
 domain-name aruba.local
 network 192.168.79.0 255.255.255.0

!
ip dhcp excluded-address 192.168.79.0 192.168.79.127
ip dhcp excluded-address 192.168.79.192 192.168.79.255
service dhcp

In general, use external DHCP servers wherever possible. Internal DHCP can be used for testing or small-scale deployments.

--
If you have urgent issues, please contact your Aruba partner or Aruba TAC (click for contact details).

View solution in original post

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: