Wireless Access

Occasional Contributor II

VIA with iOS 6 and 7 backround disconnect

This problem occurs only on the iPhone.

On Android and Windows 7 , VIA client working stable.


The problem is that after a successful connection, i put VIA in background and usin web browser, voip.

Within 1-5 minutes vpn connection is lost.


Has anyone encountered a similar problem?





Guru Elite

Re: VIA with iOS 6 and 7 backround disconnect

Please open a support case in parallel so that they can collect your logs and understand what is happening...

*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.3 User Guide
InstantOS 8.3 User Guide
Airheads Knowledgebase
Airheads Learning Videos
Occasional Contributor I

Re: VIA with iOS 6 and 7 backround disconnect

Did you get this resolved?  We had the same issue with one of our customers using VIA.  The problem was related to the policy tied to the via user role.  The via client requires communication with the controller, if this communication is not allowed between the client and the controllers internal IP address, then the client disconnects after 1 minute.  Allowing this communication in the user role that is assigned to the via client solved the issue for us.

Occasional Contributor II

Re: VIA with iOS 6 and 7 backround disconnect

I solved the problem.

Internal ip address, that i use in VIA profile was not maped to any vlan on controller.


Changing VIA profile ip to vlan ip and it fix iOS session connection drop problem.

It was my stupid mistake, but it's strange that the problem affects only on iOS.


aaa authentication via connection-profile "via-voip"
   server addr "94.228.***.***" internal-ip desc "Ent" position 0 <<<<<<<<<<<<<<<<<<<internal-ip address
   auth-profile "default" position 0
   no auto-upgrade
   tunnel address netmask
   tunnel address netmask
   tunnel address netmask
   client-wlan-profile "office" position 0
   ikev2-policy "10004"
   no windows-credentials
   no domain-pre-connect
   no validate-server-cert


Search Airheads
Showing results for 
Search instead for 
Did you mean: