日本語フォーラム

 View Only
last person joined: 3 days ago 

Arubaのソリューション、ネットワークマーケットに関する日本語ディスカッションフォーラム

[Switch] Aruba CXスイッチでCLI使いに嬉しいRunning Config表示方法

This thread has been viewed 17 times
  • 1.  [Switch] Aruba CXスイッチでCLI使いに嬉しいRunning Config表示方法

    EMPLOYEE
    Posted Dec 08, 2021 06:56 PM
    過去のスイッチ関連投稿はこちら

    スイッチの設定について、最近ではAruba Centralを使ってSD-LAN的に行ったり、
    REST APIを活用することもありますが、まだまだCLIがメインな方がほとんどではないでしょうか。

    CLIでは階層を移動して設定することも多く、設定の確認には"show running-conifg"を使うかと思いますが、
    そのまま実行すると全てのコンフィグが表示されるので、見たい場所まで流していく必要があります。
    また、| (パイプ)と"include", "begin"などを使って表示することもあるかと思います。

    今回紹介するのはCLIで今いる階層のコンフィグのみを表示する方法です。

    そのコマンドは"show running-config current-context"です。
    コマンド長いんじゃないのとツッコまれそうですが、もちろんコマンドは省略して実行できます。

    例えば"sho r c"と短くしてもOKです。
    (どれだけ簡略化できるかは階層次第となりますが、"sh r c""s r c"でも実行できることもあるようですので、
    ぜひ探してみてください)

    こちらのコマンド使うと、CLIで今いる階層のrunning-configのみを表示してくれます。
    そのため、running-configに反映されているかを確認しながら設定ができます。

    一例を記載するので参考にしてください。

    インターフェース1/1/1の設定のみを表示 ("sho r c"で表示できました)
    AOS-CX# configure terminal
    AOS-CX(config)# int 1/1/1
    AOS-CX(config-if)# sho r c
    interface 1/1/1
        no shutdown
        no routing
        vlan access 3
        loop-protect
        loop-protect action do-not-disable
        exit
    AOS-CX(config-if)#​


    インターフェースはレンジ指定で編集することも多いと思いますが、
    レンジの階層で実行すると、指定されているインターフェースの設定のみがきちんと表示されます。
    これは便利です。

    AOS-CX(config)# interface 1/1/1-1/1/2
    AOS-CX(config-if-<1/1/1-1/1/2>)# sho r c
    interface 1/1/1
        no shutdown
        no routing
        vlan access 100
        aaa authentication port-access auth-precedence mac-auth dot1x
        aaa authentication port-access client-limit 256
        aaa authentication port-access dot1x authenticator
            enable
        aaa authentication port-access mac-auth
            enable
        exit
    interface 1/1/2
        no shutdown
        no routing
        vlan access 100
        aaa authentication port-access auth-precedence mac-auth dot1x
        aaa authentication port-access client-limit 256
        aaa authentication port-access dot1x authenticator
            enable
        aaa authentication port-access mac-auth
            enable
        exit


    ACLの設定を行ったあと、確認のためそのACL設定のみを表示("s r c"で表示できました)

    AOS-CX(config)# access-list ip test-acl
    AOS-CX(config-acl-ip)# permit ip 192.168.1.0/24 192.168.2.0/24
    AOS-CX(config-acl-ip)# permit ip 192.168.1.0/24 192.168.3.0/24
    AOS-CX(config-acl-ip)# deny ip 192.168.1.0/24 192.168.4.0/24
    AOS-CX(config-acl-ip)# permit ip any any
    AOS-CX(config-acl-ip)# 
    AOS-CX(config-acl-ip)# s r c
    access-list ip test-acl
        10 permit any 192.168.1.0/255.255.255.0 192.168.2.0/255.255.255.0
        20 permit any 192.168.1.0/255.255.255.0 192.168.3.0/255.255.255.0
        30 deny any 192.168.1.0/255.255.255.0 192.168.4.0/255.255.255.0
        40 permit any any any

    この機能は元々HPE FlexFabric, FlexNetworkスイッチ製品(Comware OS製品)で"display this"というコマンドがあり、
    弊社製品を扱っていただいているエンジニアの皆様にかゆいところに手が届くと好評な機能だったんですが、
    それがAruba CXスイッチでも使えるようになっているんです。

    小ネタにはなりますが、このような情報も随時お伝えできるようにしていきたいと思います。